summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuck_Hunt2015-06-10 21:29:35 +1200
committerDuck_Hunt2015-06-10 21:29:35 +1200
commitb8e3cb1b91f3b1a3b062387f9fcbd2b7e6327524 (patch)
treeb27cc2a741888525d58cf9e19dd0d5566ed61388
downloadaur-b8e3cb1b91f3b1a3b062387f9fcbd2b7e6327524.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD54
-rw-r--r--bsnes10
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fc9195dee77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = bsnes-classic-git
+ pkgdesc = SNES emulator with Qt GUI and debugger
+ pkgver = 0.73r62.c134d41
+ pkgrel = 1
+ url = https://github.com/awjackson/bsnes-classic
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = mesa
+ makedepends = git
+ depends = libao
+ depends = libpulse
+ depends = openal
+ depends = qt4
+ depends = sdl
+ depends = xdialog
+ provides = bsnes-classic
+ conflicts = bsnes-classic
+ conflicts = bsnes-plus
+ source = git+https://github.com/awjackson/bsnes-classic.git
+ source = bsnes
+ sha256sums = SKIP
+ sha256sums = d3630df281d533312821bff1d27126df437534e39f37c7d42c1cd347d6d240b5
+
+pkgname = bsnes-classic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98e5be0a8cb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Duck Hunt <vaporeon@tfwno.gf>
+
+pkgname=bsnes-classic-git
+pkgver=0.73r62.c134d41
+pkgrel=1
+pkgdesc='SNES emulator with Qt GUI and debugger'
+arch=('i686' 'x86_64')
+url='https://github.com/awjackson/bsnes-classic'
+license=('GPL3')
+depends=('libao' 'libpulse' 'openal' 'qt4' 'sdl' 'xdialog')
+makedepends=('mesa' 'git')
+source=("git+${url}.git"
+ 'bsnes')
+sha256sums=('SKIP'
+ 'd3630df281d533312821bff1d27126df437534e39f37c7d42c1cd347d6d240b5')
+conflicts=('bsnes-classic' 'bsnes-plus')
+provides=('bsnes-classic')
+
+pkgver() {
+ cd bsnes-classic
+ printf "0.73r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ export QT_SELECT=4
+
+ cd "${srcdir}"/bsnes-classic/bsnes
+
+ for p in {accuracy,compatibility,performance}; do
+ make profile="$p"
+ mv out/bsnes{,-$p}
+ make clean
+ done
+
+ for l in {snesfilter,snesreader,supergameboy}; do
+ cd "${srcdir}"/bsnes-classic/"$l"
+ make
+ done
+}
+
+package() {
+ cd "${srcdir}"/bsnes-classic/
+ install -dm 755 "${pkgdir}"/usr/{bin,lib,share/{applications,pixmaps}}
+ install -m 755 ../bsnes "${pkgdir}"/usr/bin/
+ install -m 644 bsnes/data/bsnes.desktop "${pkgdir}"/usr/share/applications/
+ install -m 644 bsnes/data/bsnes.png "${pkgdir}"/usr/share/pixmaps/
+ install -m 644 snesfilter/libsnesfilter.so "${pkgdir}"/usr/lib/
+ install -m 644 snesreader/libsnesreader.so "${pkgdir}"/usr/lib/
+ install -m 644 supergameboy/libsupergameboy.so "${pkgdir}"/usr/lib/
+
+ for p in {accuracy,compatibility,performance}; do
+ install -m 755 bsnes/out/bsnes-$p "${pkgdir}"/usr/bin/
+ done
+} \ No newline at end of file
diff --git a/bsnes b/bsnes
new file mode 100644
index 000000000000..20fb57021421
--- /dev/null
+++ b/bsnes
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# Check for profiles and prompt user with a GUI
+[ -e /usr/bin/bsnes-accuracy ] && tag1=accuracy
+[ -e /usr/bin/bsnes-compatibility ] && tag2=compatibility
+[ -e /usr/bin/bsnes-performance ] && tag3=performance
+profile="$(Xdialog --stdout --no-tags --title "bsnes-classic" --radiolist "Choose a profile" 0 0 0 "$tag1" "Accuracy" off "$tag2" "Compatibility" off "$tag3" "Performance" off)"
+
+# Launch selected profile
+exec bsnes-$profile "$@" \ No newline at end of file