summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhvalera2023-03-15 23:44:43 +0200
committerkhvalera2023-03-15 23:44:43 +0200
commitb8e8a35f27a57a2adff8556ba5450e99b0d2d0ac (patch)
tree2417aedc940d884b906d11fe2983bf53d427e22c
parentdca6218eb24943efdf11f4ffdc69f7d650eb7236 (diff)
downloadaur-b8e8a35f27a57a2adff8556ba5450e99b0d2d0ac.tar.gz
translation update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--glpi.install5
3 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64448a20c8b5..d0db47b5170a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = glpi
pkgdesc = GLPI Inventory Management
pkgver = 10.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://www.glpi-project.org
install = glpi.install
arch = any
license = GPL
+ makedepends = gettext
depends = mysql
optdepends = nginx: a more performant webserver
optdepends = apache: a more performant webserver
@@ -33,13 +34,15 @@ pkgbase = glpi
source = glpi-cron.timer
source = downstream.php
source = local_define.php
+ source = http://snuglinux.pp.ua/local_glpi/uk_UA.po.bz2
sha256sums = d30d915a7cdc2f0e117a38e86b528f787a41e5ffdf9c3a5f9f4a1b8a70bf91ce
sha256sums = 32bd84daa949cfa1158f2c6cd8fa2593fd4bd3cc6392791b69ab24ca98eee0dd
- sha256sums = c02b51467eaf9164e8a1e988f3d2cf15ab7a05c40904140d71a18a330a42eccd
+ sha256sums = 04e40235a4a6c7d1e0daaa91e630654e632073fd5fee33bb6befa7b6f3713e44
sha256sums = c5ca6a8d1bcc73c71348d5f8a4c3de0fd023c346d1c2bf02c9dd627bcda9bfe8
sha256sums = 6b515c1c8cc44ef703fe01e53b64d6aea56ed1c833b3553233482437478d4e77
sha256sums = eea9489db1fa8f4762957eb6299dd22ca43c25f9dc62628c973a53cbcfdbab1f
sha256sums = f6ab611d8e8a4520323a6da6c469d9c30e7c713073d47aa8a2719bb8e81e5f7f
sha256sums = ac778bd538e0f2cb3195e1e5794bd57e45850bb823f30df9a7625746048a2d3d
+ sha256sums = f36ccd3ce2f45a9bfe068d236cc68632f47edad96817424ece0364e851928175
pkgname = glpi
diff --git a/PKGBUILD b/PKGBUILD
index 491ce6b67093..27cf46b840e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=glpi
pkgver=10.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="GLPI Inventory Management"
arch=('any')
url='https://www.glpi-project.org'
@@ -15,7 +15,8 @@ source=("https://github.com/glpi-project/glpi/releases/download/${pkgver}/glpi-$
'glpi-cron.service'
'glpi-cron.timer'
'downstream.php'
- 'local_define.php')
+ 'local_define.php'
+ 'http://snuglinux.pp.ua/local_glpi/uk_UA.po.bz2')
license=('GPL')
options=(!strip)
depends=("mysql")
@@ -26,14 +27,16 @@ optdepends=('nginx: a more performant webserver'
'php74' 'php74-gd' 'php74-intl' 'php74-sodium' 'php74-apache'
'php' 'php-gd' 'php-intl' 'php-sodium' 'php-apache'
'libxml2' 'zlib' 'openssl')
+makedepends=("gettext")
sha256sums=('d30d915a7cdc2f0e117a38e86b528f787a41e5ffdf9c3a5f9f4a1b8a70bf91ce'
'32bd84daa949cfa1158f2c6cd8fa2593fd4bd3cc6392791b69ab24ca98eee0dd'
- 'c02b51467eaf9164e8a1e988f3d2cf15ab7a05c40904140d71a18a330a42eccd'
+ '04e40235a4a6c7d1e0daaa91e630654e632073fd5fee33bb6befa7b6f3713e44'
'c5ca6a8d1bcc73c71348d5f8a4c3de0fd023c346d1c2bf02c9dd627bcda9bfe8'
'6b515c1c8cc44ef703fe01e53b64d6aea56ed1c833b3553233482437478d4e77'
'eea9489db1fa8f4762957eb6299dd22ca43c25f9dc62628c973a53cbcfdbab1f'
'f6ab611d8e8a4520323a6da6c469d9c30e7c713073d47aa8a2719bb8e81e5f7f'
- 'ac778bd538e0f2cb3195e1e5794bd57e45850bb823f30df9a7625746048a2d3d')
+ 'ac778bd538e0f2cb3195e1e5794bd57e45850bb823f30df9a7625746048a2d3d'
+ 'f36ccd3ce2f45a9bfe068d236cc68632f47edad96817424ece0364e851928175')
install=glpi.install
package() {
@@ -48,7 +51,6 @@ package() {
$pkgdir/var/lib \
install -dm 775 $pkgdir/var/log/glpi
-
install -Dm644 "${srcdir}"/httpd-glpi.conf $pkgdir/etc/httpd/conf/extra
ln -s LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mv *.md $pkgdir/usr/share/doc/glpi
@@ -62,4 +64,6 @@ package() {
chmod 775 $pkgdir/usr/share/webapps/glpi/marketplace
find $pkgdir/var/lib/glpi -type d -exec chmod 775 "{}" \;
rmdir "$pkgdir"/var/lib/glpi/_log
+ install -Dm644 "${srcdir}"/*.po $pkgdir/usr/share/webapps/glpi/locales/
+ msgfmt $pkgdir/usr/share/webapps/glpi/locales/uk_UA.po -o $pkgdir/usr/share/webapps/glpi/locales/uk_UA.mo
}
diff --git a/glpi.install b/glpi.install
index 15e2afa6efdd..e0b511d4d6b8 100644
--- a/glpi.install
+++ b/glpi.install
@@ -19,6 +19,11 @@ pre_upgrade() {
post_upgrade() {
post_install
+ # Needed to update the translations
+ rm -f /var/lib/glpi/_sessions/*
+ echo ">============================================================<"
+ echo -e "To update translations, do the following:\nphp /usr/share/webapps/glpi/bin/console cache:clear\nsystemctl restart httpd\n"
+ echo ">============================================================<"
}
# vim:set ts=2 sw=2 et: