summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2022-03-03 15:57:48 +0200
committerPekka Ristola2022-03-03 15:57:48 +0200
commitb91612801fe98f0a16cbd8ca2e26e74ad4756ba1 (patch)
treef85955743e115235dadf26a1823bffecd4c4c97f
downloadaur-b91612801fe98f0a16cbd8ca2e26e74ad4756ba1.tar.gz
Version 1.1.1
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb177a4addae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-lobstr
+ pkgdesc = Visualize R Data Structures with Trees
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=lobstr
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ checkdepends = r-testthat
+ depends = r-crayon
+ depends = r-rcpp
+ depends = r-rlang
+ optdepends = r-covr
+ optdepends = r-pillar
+ optdepends = r-pkgdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/lobstr_1.1.1.tar.gz
+ sha256sums = b8c9ce00095bd4f304b4883ef71da24572022f0632a18c3e1ba317814e70716e
+
+pkgname = r-lobstr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ab97b148474
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_cranname=lobstr
+_cranver=1.1.1
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Visualize R Data Structures with Trees"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL3)
+depends=(r-crayon r-rcpp r-rlang)
+checkdepends=(r-testthat)
+optdepends=(
+ r-covr
+ r-pillar
+ r-pkgdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('b8c9ce00095bd4f304b4883ef71da24572022f0632a18c3e1ba317814e70716e')
+
+prepare() {
+ # Fix test
+ sed -i '10 s/<list>/<named list>/' \
+ "${_cranname}/tests/testthat/test-ref-list.txt"
+}
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+}
+
+check() {
+ cd "${_cranname}/tests"
+ R_LIBS="${srcdir}/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+
+ cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+}