summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoungjae Lee2023-03-01 00:10:55 +0900
committerYoungjae Lee2023-03-01 00:10:55 +0900
commitb923c8ea5da9c03ad038daf7e0280937d672dcf6 (patch)
tree2f213f0e3ab731be6f6ac9623b37127ad7d5499a
parentd43c50b3f3253e81f443f1839bdce8ef54d729c9 (diff)
downloadaur-b923c8ea5da9c03ad038daf7e0280937d672dcf6.tar.gz
WiredTiger 11.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
-rw-r--r--include_optional.patch12
3 files changed, 46 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d718a464182..74b33a24cb7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = wiredtiger
- pkgdesc = High performance NoSQL platform
- pkgver = 10.0.0
+ pkgdesc = High performance, scalable, NoSQL, extensible platform for data management
+ pkgver = 11.1.0
pkgrel = 1
- url = https://source.wiredtiger.com
+ url = https://github.com/wiredtiger/wiredtiger
arch = x86_64
license = GPL
- depends = snappy
+ makedepends = cmake
+ makedepends = swig
depends = lz4
+ depends = snappy
depends = zlib
depends = zstd
- depends = gperftools
- source = wiredtiger-10.0.0.tar.gz::https://github.com/wiredtiger/wiredtiger/archive/10.0.0.tar.gz
- sha512sums = 6e2d0fa1e20467ce6d39d4ac097b0bad9954e10f6ff72dc35b02871f9ce5492a889899560065dfdf8d60f966f1d3cf0b3b8490ab017a4199bdcab9d190e77bb0
- b2sums = 2b9b85bd7711c114a9b6e3c8cd0db3ce8ba6d08efd3b7b8e39ceff8cd251147c9d9a13942353ec885b7542f732d25946befd814fc046225bfde6ae6d31097c10
+ source = wiredtiger-11.1.0.tar.gz::https://github.com/wiredtiger/wiredtiger/archive/refs/tags/11.1.0.tar.gz
+ source = include_optional.patch
+ sha256sums = 0d988a8256219b614d855a2504d252975240171a633b882f19149c4a2ce0ec3d
+ sha256sums = c90ae01194c0cdc11c3c967289605ba2ba6fc302ad79fbb7e0e85075b81b85a0
pkgname = wiredtiger
diff --git a/PKGBUILD b/PKGBUILD
index 690468853c14..b95efab73b9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,37 @@
-# Maintainer: George Rawlinson <george@rawlinson.net.nz>
+# Maintainer: Youngjae Lee <ls4154.lee@gmail.com>
+# Contributor: George Rawlinson <george@rawlinson.net.nz>
# Contributor: Christoph Bayer <chrbayer@criby.de>
# Contributor: James P. Harvey <jamespharvey20 at gmail dot com>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=wiredtiger
-pkgver=10.0.0
+pkgver=11.1.0
pkgrel=1
-pkgdesc="High performance NoSQL platform"
-arch=('x86_64')
-url="https://source.wiredtiger.com"
-license=('GPL')
-depends=('snappy' 'lz4' 'zlib' 'zstd' 'gperftools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/wiredtiger/wiredtiger/archive/$pkgver.tar.gz")
-sha512sums=('6e2d0fa1e20467ce6d39d4ac097b0bad9954e10f6ff72dc35b02871f9ce5492a889899560065dfdf8d60f966f1d3cf0b3b8490ab017a4199bdcab9d190e77bb0')
-b2sums=('2b9b85bd7711c114a9b6e3c8cd0db3ce8ba6d08efd3b7b8e39ceff8cd251147c9d9a13942353ec885b7542f732d25946befd814fc046225bfde6ae6d31097c10')
+pkgdesc="High performance, scalable, NoSQL, extensible platform for data management"
+arch=("x86_64")
+url="https://github.com/wiredtiger/wiredtiger"
+license=("GPL")
+depends=("lz4" "snappy" "zlib" "zstd")
+makedepends=("cmake" "swig")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wiredtiger/$pkgname/archive/refs/tags/$pkgver.tar.gz"
+ "include_optional.patch")
+sha256sums=("0d988a8256219b614d855a2504d252975240171a633b882f19149c4a2ce0ec3d"
+ "c90ae01194c0cdc11c3c967289605ba2ba6fc302ad79fbb7e0e85075b81b85a0")
-build() {
- cd "$pkgname-$pkgver"
- ./autogen.sh
- ./configure \
- --prefix=/usr \
- --enable-tcmalloc \
- --with-builtins=snappy,lz4,zlib,zstd
+prepare() {
+ patch -d "$pkgname-$pkgver" -p1 < include_optional.patch
+}
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr \
+ -DHAVE_BUILTIN_EXTENSION_LZ4=1 -DHAVE_BUILTIN_EXTENSION_SNAPPY=1 \
+ -DHAVE_BUILTIN_EXTENSION_ZLIB=1 -DHAVE_BUILTIN_EXTENSION_ZSTD=1 .
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver"
-
- # NOTE there is no `make` in build() because it compiles & runs broken tests
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" cmake --install build
}
diff --git a/include_optional.patch b/include_optional.patch
new file mode 100644
index 000000000000..a5815f5ad10b
--- /dev/null
+++ b/include_optional.patch
@@ -0,0 +1,12 @@
+diff --git a/test/cppsuite/src/main/thread_worker.h b/test/cppsuite/src/main/thread_worker.h
+index afc4c8366..e8376401b 100644
+--- a/test/cppsuite/src/main/thread_worker.h
++++ b/test/cppsuite/src/main/thread_worker.h
+@@ -30,6 +30,7 @@
+ #define THREAD_WORKER_H
+
+ #include <string>
++#include <optional>
+
+ #include "database.h"
+ #include "src/component/operation_tracker.h"