summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeng Yu2024-02-15 10:49:50 +0800
committerFeng Yu2024-02-15 10:49:50 +0800
commitb9242bc207d4375b398d1a0066bf1bbd6e3cce08 (patch)
tree7d77ebe4029e6a7bb1211482d5c3fe3a10e604e5
parent5f250e10b9f51df2cc1f87a3770d5873fd9914ff (diff)
downloadaur-b9242bc207d4375b398d1a0066bf1bbd6e3cce08.tar.gz
fix update.sh issue
-rwxr-xr-xupdate.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/update.sh b/update.sh
index 17f406e252b7..a72f55aa5b5f 100755
--- a/update.sh
+++ b/update.sh
@@ -5,7 +5,7 @@ SELF_DIR="$(dirname "${BASH_SOURCE[0]}")"
source "${SELF_DIR}/PKGBUILD"
echo "Current version: ${pkgver}"
echo -n "Checking latest version... "
-LATEST_VER="$(curl -si https://github.com/lyswhut/lx-music-desktop/releases/latest | sed -nr 's@^location:.*/v(\w*)@\1@p')"
+LATEST_VER="$(curl -si https://github.com/lyswhut/lx-music-desktop/releases/latest | sed -nr 's@^location:.*/v([[:alnum:]\.]+)\r?@\1@p')"
echo "${LATEST_VER}"
if [ "${LATEST_VER}" = ${pkgver} ]; then