summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-08 22:39:48 +0100
committerCarsten Teibes2014-01-08 22:39:48 +0100
commitb932c93e4b0b7603de040d8b389294e74c678d6b (patch)
treee864d4ae3611fa4b851009aa5a7add865db70a16
parentdcb02d8aefdfe8f8b308cbb2f0b0083efe2e18e3 (diff)
downloadaur-b932c93e4b0b7603de040d8b389294e74c678d6b.tar.gz
Cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0648fb2d6ed9..8d0a8b81134d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,10 +14,10 @@ pkgbase = gtkhash-git
optdepends = nemo: filemanager plugin
provides = gtkhash
conflicts = gtkhash
- source = gtkhash::git://github.com/tristanheaven/gtkhash.git
+ source = gtkhash::git+https://github.com/tristanheaven/gtkhash.git
source = gtkhash.desktop
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = SKIP
+ sha256sums = f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388
pkgname = gtkhash-git
diff --git a/PKGBUILD b/PKGBUILD
index 19494133436a..f9ad895ae91d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
##### OPTIONS #####
_gtk_version=3
@@ -17,12 +17,13 @@ url='http://gtkhash.sourceforge.net/'
license=('GPL')
makedepends=('intltool')
depends=('dconf')
-install=$_pkgbase.install
-source=("$_pkgbase::git://github.com/tristanheaven/gtkhash.git"
- "$_pkgbase.desktop")
conflicts=("$_pkgbase")
provides=("$_pkgbase")
-md5sums=('SKIP' 'SKIP')
+install=$_pkgbase.install
+source=($_pkgbase::"git+https://github.com/tristanheaven/gtkhash.git"
+ "$_pkgbase.desktop")
+sha256sums=('SKIP'
+ 'f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388')
# gtk version
if [ "$_gtk_version" = "3" ]; then
@@ -67,15 +68,14 @@ build() {
./autogen.sh
./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
--enable-linux-crypto --enable-nettle $_pkgoptions
-
make
}
package() {
cd $_pkgbase
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir/" install
# install desktop entry
- install -Dm644 ../gtkhash.desktop $pkgdir/usr/share/applications/gtkhash.desktop
+ install -Dm644 ../gtkhash.desktop "$pkgdir"/usr/share/applications/gtkhash.desktop
}