summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-03-20 11:06:37 +0100
committertytan6522021-03-20 11:06:37 +0100
commitb964fffb3c8252055205d9e87259239bdb4e437e (patch)
treeb355b33695b3f8ea09037ee15167c62204f76f82
parent973b1efffdeedb75d0826ddc3a9db6a6df5cd7fb (diff)
downloadaur-b964fffb3c8252055205d9e87259239bdb4e437e.tar.gz
build: use the right repo
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD34
3 files changed, 42 insertions, 40 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 65fd5345b26a..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,20 +0,0 @@
-pkgbase = zbar-git
- pkgdesc = Application and library for reading bar codes from various sources
- pkgver = iPhoneSDK.1.3.1.r10.g453a338
- pkgrel = 1
- url = http://zbar.sourceforge.net/
- arch = i686
- arch = x86_64
- arch = armv6h
- arch = armv7h
- license = LGPL
- depends = v4l-utils
- depends = autoconf
- conflicts = zbar-gtk
- conflicts = zbar-qt
- conflicts = zbar
- source = zbar-git::git://github.com/vbmithr/ZBar#branch=neon
- md5sums = SKIP
-
-pkgname = zbar-git
-
diff --git a/.SRCINFO b/.SRCINFO
index 65fd5345b26a..640728250406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,33 @@
pkgbase = zbar-git
pkgdesc = Application and library for reading bar codes from various sources
- pkgver = iPhoneSDK.1.3.1.r10.g453a338
+ pkgver = 0.23.92.r22.g4e0f618
pkgrel = 1
- url = http://zbar.sourceforge.net/
+ url = https://github.com/mchehab/zbar
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
+ arch = aarch64
license = LGPL
+ makedepends = gtk3
+ makedepends = qt5-x11extras
+ makedepends = python
+ makedepends = xmlto
+ makedepends = docbook-xsl
+ makedepends = gobject-introspection
+ depends = dbus
+ depends = imagemagick
+ depends = libsm
+ depends = libxv
depends = v4l-utils
- depends = autoconf
- conflicts = zbar-gtk
- conflicts = zbar-qt
- conflicts = zbar
- source = zbar-git::git://github.com/vbmithr/ZBar#branch=neon
+ optdepends = gtk3: for zbar-gtk
+ optdepends = qt5-x11extras: for zbar-qt
+ optdepends = python: for zbar python bindings
+ provides = zbar
+ provides = zbar-gtk
+ provides = zbar-qt
+ provides = python-zbar
+ source = zbar-git::git+https://github.com/mchehab/zbar.git
md5sums = SKIP
pkgname = zbar-git
diff --git a/PKGBUILD b/PKGBUILD
index aa0db2bba1c7..2c3d4ba89440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Marti Raudsepp <marti@juffo.org>
-# Contributor: Radu Andries <admiral0@tuxfamily.org>
-# Contributor: Andy Weidenbaum <archbaum@gmail.com>
-# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=zbar-git
-pkgver=iPhoneSDK.1.3.1.r10.g453a338
+pkgver=0.23.92.r22.g4e0f618
pkgrel=1
pkgdesc="Application and library for reading bar codes from various sources"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="http://zbar.sourceforge.net/"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/mchehab/zbar"
license=('LGPL')
-depends=('v4l-utils' 'autoconf')
-conflicts=('zbar-gtk' 'zbar-qt' 'zbar')
-source=("$pkgname"::'git://github.com/vbmithr/ZBar#branch=neon')
+depends=('dbus' 'imagemagick' 'libsm' 'libxv' 'v4l-utils')
+makedepends=('gtk3' 'qt5-x11extras' 'python' 'xmlto' 'docbook-xsl' 'gobject-introspection')
+optdepends=('gtk3: for zbar-gtk'
+ 'qt5-x11extras: for zbar-qt'
+ 'python: for zbar python bindings')
+provides=('zbar' 'zbar-gtk' 'zbar-qt' 'python-zbar')
+source=("$pkgname"::'git+https://github.com/mchehab/zbar.git')
md5sums=('SKIP')
pkgver() {
@@ -20,12 +21,19 @@ pkgver() {
git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ autoreconf -vfi
+
+ # Removed in Python 3.9. Ignored in Python 3.0+ anyway.
+ sed -i '/tp_print/d' python/enum.c
+}
+
build() {
cd "$pkgname"
- autoreconf --install
- ./configure --prefix=/usr --without-python --without-qt --without-gtk
-
+ ./configure --prefix=/usr --with-qt --with-gtk=gtk3 --with-dbusconfdir=/usr/share CFLAGS="$CFLAGS -DNDEBUG"
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}