summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-05-09 15:13:34 +0200
committerMarcin Wieczorek2016-05-09 15:13:34 +0200
commitb96742a56236fb84d9ad1287a092be3a05b18ade (patch)
tree7764770bbf66b06a1062da4b81f079bc678a1be0
downloadaur-b96742a56236fb84d9ad1287a092be3a05b18ade.tar.gz
Version 0.3a
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--supermodel.install12
-rw-r--r--supermodel.sh12
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9ad7456b1b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = supermodel-svn
+ pkgdesc = A Sega Model 3 Arcade Emulator
+ pkgver = 0.3a
+ pkgrel = 1
+ url = http://www.supermodel3.com/
+ install = supermodel.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = mesa
+ depends = sdl
+ depends = zlib
+ source = supermodel.sh
+ source = supermodel-svn::svn+https://svn.code.sf.net/p/model3emu/code/trunk
+ md5sums = ea8274c2a37acddd026fce9c831530cc
+ md5sums = SKIP
+
+pkgname = supermodel-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..027a49c77e8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Contributor: Anton Shestakov <engored@ya.ru>
+
+pkgname=supermodel-svn
+pkgver=0.3a
+pkgrel=1
+pkgdesc='A Sega Model 3 Arcade Emulator'
+arch=('i686' 'x86_64')
+url='http://www.supermodel3.com/'
+license=('GPL3')
+depends=('mesa' 'sdl' 'zlib')
+install=supermodel.install
+source=('supermodel.sh'
+ "${pkgname}::svn+https://svn.code.sf.net/p/model3emu/code/trunk")
+
+md5sums=('ea8274c2a37acddd026fce9c831530cc'
+ 'SKIP')
+
+MAKEFLAGS="-j1"
+
+build() {
+ cd "${srcdir}/supermodel-svn/"
+ sed -e "s/-Wall -O3/$CFLAGS/" -i 'Makefiles/Makefile.SDL.UNIX.GCC'
+ # patch -p1 < ../multiuser.patch
+ make -f 'Makefiles/Makefile.SDL.UNIX.GCC'
+}
+
+package() {
+ cd "${srcdir}/supermodel-svn/"
+
+ install -Dm755 "$srcdir/supermodel.sh" "$pkgdir/usr/bin/supermodel"
+
+ install -Dm755 "bin/Supermodel" "$pkgdir/usr/share/supermodel/Supermodel"
+
+ install -Dm644 "Docs/LICENSE.txt" "$pkgdir/usr/share/licenses/supermodel/LICENSE"
+ install -Dm644 "Docs/README.txt" "$pkgdir/usr/share/doc/supermodel/README"
+
+ install -d "$pkgdir/usr/share/supermodel/Config"
+ install -m644 Config/* "$pkgdir/usr/share/supermodel/Config/"
+}
diff --git a/supermodel.install b/supermodel.install
new file mode 100644
index 000000000000..94ef82c4886a
--- /dev/null
+++ b/supermodel.install
@@ -0,0 +1,12 @@
+# Message displayed for a fresh install.
+post_install() {
+ echo ""
+ echo "***************************************************************"
+ echo " Supermodel has been installed in /usr/share/supermodel."
+ echo " However, Supermodel can be run by typing supermodel and it's options:"
+ echo " supermodel <romset> [options]"
+ echo ""
+ echo " Note: You need to provide the full path to the romset."
+ echo "***************************************************************"
+ echo ""
+}
diff --git a/supermodel.sh b/supermodel.sh
new file mode 100644
index 000000000000..992dd406d0d6
--- /dev/null
+++ b/supermodel.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+mkdir -p ~/.supermodel/NVRAM
+mkdir -p ~/.supermodel/saves
+
+cd /usr/share/supermodel
+
+if [[ ! -f ~/.supermodel/supermodel.ini ]]; then
+ cp ./Config/Supermodel.ini ~/.supermodel/supermodel.ini
+fi
+
+./Supermodel "$@"