summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-05-10 21:42:44 +0200
committerFabioLolix2020-05-10 21:42:44 +0200
commitb97a1aafddc5b0f6311ebb192184e64b84dbfbfd (patch)
tree88792ea3bcf93b602c06ee599465cc2dd2e03c75
parent5bc6b7e4f14036fec043a1e77734b1365e05799b (diff)
downloadaur-b97a1aafddc5b0f6311ebb192184e64b84dbfbfd.tar.gz
update contact info
-rwxr-xr-x.SRCINFO9
-rwxr-xr-xPKGBUILD32
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e62dfd8030c..1ae21c3a0db2 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = gmusicbrowser-git
pkgdesc = An open-source jukebox for large collections of mp3/ogg/flac files, written in perl.
- pkgver = 1.1.15.r42.g2d57cef
- pkgrel = 2
+ pkgver = 1.1.15.r54.g4538a5a
+ pkgrel = 1
url = http://gmusicbrowser.org/
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = markdown
@@ -28,8 +29,8 @@ pkgbase = gmusicbrowser-git
optdepends = perl-gtk2-notify: support for notify plugin
provides = gmusicbrowser
conflicts = gmusicbrowser
- source = gmusicbrowser-git::git+http://github.com/squentin/gmusicbrowser.git
- md5sums = SKIP
+ source = git+http://github.com/squentin/gmusicbrowser.git
+ sha256sums = SKIP
pkgname = gmusicbrowser-git
diff --git a/PKGBUILD b/PKGBUILD
index ea9e5bd8f756..51c0eeaa2821 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Contributor: Fabio Loli <loli_fabio@protonmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: RobbeR49 <robertsna@gmail.com>
pkgname=gmusicbrowser-git
-pkgver=1.1.15.r42.g2d57cef
-pkgrel=2
+pkgver=1.1.15.r54.g4538a5a
+pkgrel=1
pkgdesc="An open-source jukebox for large collections of mp3/ogg/flac files, written in perl."
-arch=('i686' 'x86_64')
+arch=(i686 x86_64 aarch64)
url="http://gmusicbrowser.org/"
-license=('GPL3')
-depends=('gtk2-perl' 'perl-net-dbus' 'perl-locale-gettext' 'perl-glib-object-introspection')
-makedepends=('git' 'markdown')
+license=(GPL3)
+depends=(gtk2-perl perl-net-dbus perl-locale-gettext perl-glib-object-introspection)
+makedepends=(git markdown)
optdepends=('alsa-utils: enables the ALSA backend'
'flac123: flac support for the ALSA backend'
'mpg321: mp3 support for the ALSA backend'
@@ -24,22 +24,22 @@ optdepends=('alsa-utils: enables the ALSA backend'
'perl-gnome2-wnck: titlebar plugin support'
'perl-html-parser: support for accented characters in lyrics plugin'
'perl-gtk2-notify: support for notify plugin')
-provides=('gmusicbrowser')
-conflicts=('gmusicbrowser')
-source=("${pkgname}::git+http://github.com/squentin/gmusicbrowser.git")
-md5sums=('SKIP')
+provides=(gmusicbrowser)
+conflicts=(gmusicbrowser)
+source=("git+http://github.com/squentin/gmusicbrowser.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "${srcdir}/${pkgname%-git}"
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname}"
- make
+ cd "${srcdir}/${pkgname%-git}"
+ make
}
package() {
- cd "${srcdir}/${pkgname}"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
}