summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-03-29 19:21:20 -0400
committerAndrew Sun2019-03-29 19:21:20 -0400
commitb9881286c00b0a67309de0a82421bb7f0c60cd7d (patch)
tree13e0d7ab09d2f118b2bc22cd5d8caceb19500a84
parentd704a875ffd636f924cd32cbaab47299bd044e3f (diff)
downloadaur-b9881286c00b0a67309de0a82421bb7f0c60cd7d.tar.gz
mingw-w64-curl: update to 7.64.1
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Make-cURL-relocatable.patch18
-rw-r--r--0003-libpsl-static-libs.patch20
-rw-r--r--PKGBUILD9
4 files changed, 28 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0066726854ad..75250e608cb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = mingw-w64-curl
pkgdesc = An URL retrival utility and library (mingw-w64)
- pkgver = 7.64.0
+ pkgver = 7.64.1
pkgrel = 1
url = http://curl.haxx.se
arch = any
license = MIT
makedepends = mingw-w64-configure
depends = mingw-w64-crt
- depends = mingw-w64-gnutls
depends = mingw-w64-libidn2
depends = mingw-w64-libpsl
depends = mingw-w64-libssh2
@@ -16,14 +15,14 @@ pkgbase = mingw-w64-curl
options = staticlibs
options = !strip
options = !buildflags
- source = http://curl.haxx.se/download/curl-7.64.0.tar.bz2
+ source = http://curl.haxx.se/download/curl-7.64.1.tar.bz2
source = 0001-Make-cURL-relocatable.patch
source = 0002-nghttp2-static.patch
source = 0003-libpsl-static-libs.patch
- sha256sums = d573ba1c2d1cf9d8533fadcce480d778417964e8d04ccddcc76e591d544cf2eb
- sha256sums = 5d29129b312500c94c4e94cbcdee2fb54148b5788837761534aabb698484f4d4
+ sha256sums = 4cc7c738b35250d0680f29e93e0820c4cb40035f43514ea3ec8d60322d41a45d
+ sha256sums = f98fcdf99da76944e3a85da3b6d5bdfce931a2d32c3011c6492273fd2d6078b5
sha256sums = 963368c3fdc16f37eef6b1f5b8afa99d7c945b7ae06cc636d3d6277e330c93fb
- sha256sums = 5d6563e29e85c7fadd129308e9927450c59fe5d429d9b27aafd3460bfc40defb
+ sha256sums = 7492d019036b5bec251bfbc3c0b40e5f16d3dd6b2515068835e087a6c21f19ad
pkgname = mingw-w64-curl
diff --git a/0001-Make-cURL-relocatable.patch b/0001-Make-cURL-relocatable.patch
index a236de4b7e61..fa39a73ba44b 100644
--- a/0001-Make-cURL-relocatable.patch
+++ b/0001-Make-cURL-relocatable.patch
@@ -45,21 +45,21 @@ diff --git a/lib/Makefile.inc b/lib/Makefile.inc
index 69f9b403d..44e2dc039 100644
--- a/lib/Makefile.inc
+++ b/lib/Makefile.inc
-@@ -54,7 +54,7 @@ LIB_CFILES = file.c timeval.c base64.c hostip.c progress.c formdata.c \
+@@ -55,7 +55,7 @@
curl_multibyte.c hostcheck.c conncache.c pipeline.c dotdot.c \
x509asn1.c http2.c smb.c curl_endian.c curl_des.c system_win32.c \
mime.c sha256.c setopt.c curl_path.c curl_ctype.c curl_range.c psl.c \
-- doh.c urlapi.c
-+ doh.c urlapi.c pathtools.c
+- doh.c urlapi.c altsvc.c
++ doh.c urlapi.c altsvc.c pathtools.c
LIB_HFILES = arpa_telnet.h netrc.h file.h timeval.h hostip.h progress.h \
formdata.h cookie.h http.h sendf.h ftp.h url.h dict.h if2ip.h \
-@@ -74,7 +75,7 @@ LIB_HFILES = arpa_telnet.h netrc.h file.h timeval.h hostip.h progress.h \
- curl_setup_once.h multihandle.h setup-vms.h pipeline.h dotdot.h \
+@@ -76,7 +76,7 @@
x509asn1.h http2.h sigpipe.h smb.h curl_endian.h curl_des.h \
curl_printf.h system_win32.h rand.h mime.h curl_sha256.h setopt.h \
-- curl_path.h curl_ctype.h curl_range.h psl.h doh.h urlapi-int.h
-+ curl_path.h curl_ctype.h curl_range.h psl.h doh.h urlapi-int.h pathtools.h
+ curl_path.h curl_ctype.h curl_range.h psl.h doh.h urlapi-int.h \
+- altsvc.h
++ altsvc.h pathtools.h
LIB_RCFILES = libcurl.rc
@@ -679,10 +679,10 @@ diff --git a/lib/url.c b/lib/url.c
index 945d4e327..981e60d26 100644
--- a/lib/url.c
+++ b/lib/url.c
-@@ -119,6 +119,9 @@ bool curl_win32_idn_to_ascii(const char *in, char **out);
- #include "dotdot.h"
+@@ -121,6 +121,9 @@
#include "strdup.h"
#include "setopt.h"
+ #include "altsvc.h"
+#if defined(__MINGW32__)
+#include "pathtools.h"
+#endif
diff --git a/0003-libpsl-static-libs.patch b/0003-libpsl-static-libs.patch
index 98420512260a..ce33b87eedb5 100644
--- a/0003-libpsl-static-libs.patch
+++ b/0003-libpsl-static-libs.patch
@@ -1,11 +1,11 @@
---- curl-7.58.0/configure.ac.orig 2018-02-12 11:45:28.253147200 +0300
-+++ curl-7.58.0/configure.ac 2018-02-12 11:51:12.894795500 +0300
-@@ -2618,14 +2618,30 @@
+--- curl-7.64.1.orig/configure.ac 2019-03-29 18:14:22.692813700 -0400
++++ curl-7.64.1/configure.ac 2019-03-29 18:52:44.514352300 -0400
+@@ -2747,14 +2747,30 @@
with_libpsl=$withval,
with_libpsl=yes)
if test $with_libpsl != "no"; then
- AC_SEARCH_LIBS(psl_builtin, psl,
-- [curl_psl_msg="yes";
+- [curl_psl_msg="enabled";
- AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
- ],
- [curl_psl_msg="no (libpsl not found)";
@@ -27,15 +27,15 @@
+ else
+ dnl no nghttp2 pkg-config found, deal with it
+ AC_SEARCH_LIBS(psl_builtin, psl,
-+ [curl_psl_msg="yes";
-+ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
-+ ],
++ [curl_psl_msg="enabled";
++ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
++ ],
+ [curl_psl_msg="no (libpsl not found)";
-+ AC_MSG_WARN([libpsl was not found])
-+ ]
++ AC_MSG_WARN([libpsl was not found])
++ ]
+ )
+ fi
+
fi
- AM_CONDITIONAL([USE_LIBPSL], [test "$curl_psl_msg" = "yes"])
+ AM_CONDITIONAL([USE_LIBPSL], [test "$curl_psl_msg" = "enabled"])
diff --git a/PKGBUILD b/PKGBUILD
index de719dafcc5e..467b18b4af17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Contributor: ant32 <antreimer@gmail.com>
pkgname=mingw-w64-curl
-pkgver=7.64.0
+pkgver=7.64.1
pkgrel=1
pkgdesc="An URL retrival utility and library (mingw-w64)"
arch=('any')
url="http://curl.haxx.se"
license=("MIT")
depends=('mingw-w64-crt'
- 'mingw-w64-gnutls'
'mingw-w64-libidn2'
'mingw-w64-libpsl'
'mingw-w64-libssh2'
@@ -21,10 +20,10 @@ source=("$url/download/curl-$pkgver.tar.bz2"
"0001-Make-cURL-relocatable.patch"
"0002-nghttp2-static.patch"
"0003-libpsl-static-libs.patch")
-sha256sums=('d573ba1c2d1cf9d8533fadcce480d778417964e8d04ccddcc76e591d544cf2eb'
- '5d29129b312500c94c4e94cbcdee2fb54148b5788837761534aabb698484f4d4'
+sha256sums=('4cc7c738b35250d0680f29e93e0820c4cb40035f43514ea3ec8d60322d41a45d'
+ 'f98fcdf99da76944e3a85da3b6d5bdfce931a2d32c3011c6492273fd2d6078b5'
'963368c3fdc16f37eef6b1f5b8afa99d7c945b7ae06cc636d3d6277e330c93fb'
- '5d6563e29e85c7fadd129308e9927450c59fe5d429d9b27aafd3460bfc40defb')
+ '7492d019036b5bec251bfbc3c0b40e5f16d3dd6b2515068835e087a6c21f19ad')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"