summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-01-25 09:29:29 +0300
committerCaleb Maclennan2021-01-25 09:29:29 +0300
commitb98ad07fba71df220a67ae9de0395784dd0cc04b (patch)
tree4dcf7ef49c447a938646caa251d5b0ad4ce9911b
parentf10d301b627e7668da2ba7b8ab537688b3d35d70 (diff)
downloadaur-b98ad07fba71df220a67ae9de0395784dd0cc04b.tar.gz
upgpkg: ijq 0.2.3-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ffb9ee544c0..6a073159c92c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ijq
pkgdesc = Interactive jq tool, like jqplay for the commandline
pkgver = 0.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://git.sr.ht/~gpanders/ijq
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index c7fd9909719d..1cfa4a9d8302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ijq
pkgver=0.2.3
-pkgrel=1
+pkgrel=2
pkgdesc='Interactive jq tool, like jqplay for the commandline'
arch=(x86_64)
url="https://git.sr.ht/~gpanders/$pkgname"
@@ -16,6 +16,8 @@ prepare(){
cd "$pkgname-v$pkgver"
export GOPATH="$srcdir"
go mod download
+ # release has broken go.sum file
+ go mod tidy
}
build() {
@@ -24,10 +26,10 @@ build() {
go build \
-trimpath \
-buildmode=pie \
+ -mod=readonly \
-modcacherw \
-ldflags "-linkmode external -extldflags \"$LDFLAGS\"" \
. ./...
- # -mod=readonly \
}
check() {
@@ -38,5 +40,5 @@ check() {
package() {
cd "$pkgname-v$pkgver"
- install -Dm755 -t "$pkgdir/usr/bin/" $pkgname
+ install -Dm755 -t "$pkgdir/usr/bin/" "$pkgname"
}