summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2024-02-03 19:52:05 +0100
committerD3SOX2024-02-03 19:52:05 +0100
commitb9977f04f9e38d2354e864ae6c8a98146afa54db (patch)
tree051fa01f04da92eca869846e8edca0dd41687fd4
parentd3e4f16596e09ac315638b6311b94cecba70517c (diff)
downloadaur-b9977f04f9e38d2354e864ae6c8a98146afa54db.tar.gz
update to inter 4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62522be4e3ff..052179a48687 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-inter
pkgdesc = Inter Font, patched with the Nerd Fonts Patcher
- pkgver = 3.19_3.1.1
- pkgrel = 2
+ pkgver = 4.0_3.1.1
+ pkgrel = 1
url = https://github.com/rsms/inter/
arch = any
license = custom:OFL
@@ -11,9 +11,9 @@ pkgbase = nerd-fonts-inter
makedepends = fontforge
makedepends = subversion
makedepends = parallel
- source = https://github.com/rsms/inter/releases/download/v3.19/Inter-3.19.zip
+ source = https://github.com/rsms/inter/releases/download/v4.0/Inter-4.0.zip
source = font-patcher-3.1.1::https://github.com/ryanoasis/nerd-fonts/releases/download/v3.1.1/FontPatcher.zip
- sha256sums = 150ab6230d1762a57bebf35dfc04d606ff91598a31d785f7f100356ecdcc0032
+ sha256sums = ff970a5d4561a04f102a7cb781adbd6ac4e9b6c460914c7a101f15acb7f7d1a4
sha256sums = 7b11bdbbe645ff817192233f7fab1dc026cea201959dc4617f5217d5250de4f2
pkgname = nerd-fonts-inter
diff --git a/PKGBUILD b/PKGBUILD
index 0cc3ec53a9e7..a4482489fc12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=nerd-fonts-inter
-_interver=3.19
+_interver=4.0
_nfver=3.1.1
pkgver="${_interver}_${_nfver}"
-pkgrel=2
+pkgrel=1
pkgdesc="Inter Font, patched with the Nerd Fonts Patcher"
arch=('any')
url='https://github.com/rsms/inter/'
license=('custom:OFL')
makedepends=('git' 'p7zip' 'python' 'fontforge' 'subversion' 'parallel')
source=("https://github.com/rsms/inter/releases/download/v$_interver/Inter-$_interver.zip" "font-patcher-$_nfver::https://github.com/ryanoasis/nerd-fonts/releases/download/v$_nfver/FontPatcher.zip")
-sha256sums=('150ab6230d1762a57bebf35dfc04d606ff91598a31d785f7f100356ecdcc0032'
+sha256sums=('ff970a5d4561a04f102a7cb781adbd6ac4e9b6c460914c7a101f15acb7f7d1a4'
'7b11bdbbe645ff817192233f7fab1dc026cea201959dc4617f5217d5250de4f2')
build() {
@@ -19,7 +19,7 @@ build() {
mkdir -p "$srcdir/patched"
printf "%b" "\e[1;33m==> WARNING: \e[0mNow patching all fonts. This will take very long...\n"
# patch fonts quiet with complete glyphs
- parallel -j$(nproc) python "$srcdir/font-patcher" --variable-width-glyphs -q -c {} -out "$srcdir/patched" &> /dev/null ::: "$srcdir/Inter Desktop"/*.otf
+ parallel -j$(nproc) python "$srcdir/font-patcher" --variable-width-glyphs -q -c {} -out "$srcdir/patched" &> /dev/null ::: "$srcdir/extras/otf"/*.otf
}
package() {