summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaez0pub2017-10-15 19:45:04 +0200
committersaez0pub2017-10-15 19:45:04 +0200
commitb9a0975e1c2c3e7a5f1de30c0b2deca8f32d8b4f (patch)
treef418cde4a39dfc198b2b7705a5fdffa03e79767f
downloadaur-b9a0975e1c2c3e7a5f1de30c0b2deca8f32d8b4f.tar.gz
first version on aur
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
-rw-r--r--dashticz.install8
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9dd8341e9cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dashticz-git
+ pkgdesc = Alternative dashboard for Domoticz
+ pkgver = 2.r3127
+ pkgrel = 1
+ url = https://github.com/robgeerts/dashticz_v2/tree/master
+ install = dashticz.install
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ depends = domoticz
+ source = git+https://github.com/robgeerts/dashticz_v2.git
+ source = dashticz.install
+ sha256sums = SKIP
+ sha256sums = a87b3c6299d9e33fc985d76c2ba6034f15a3cc5221b0379d758c00fffe0a16d4
+
+pkgname = dashticz-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42985dc2f0bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.txt
+src/
+pkg/
+dashticz_v2/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0ef5b29451f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: IanDury
+
+pkgname=dashticz-git
+pkgver=2.r3127
+pkgrel=1
+pkgdesc="Alternative dashboard for Domoticz"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/robgeerts/dashticz_v2/tree/master"
+#license=('GPL') ?
+depends=('domoticz')
+install='dashticz.install'
+makepends=('coreutils')
+source=("git+https://github.com/robgeerts/dashticz_v2.git"
+ 'dashticz.install')
+sha256sums=('SKIP'
+ 'a87b3c6299d9e33fc985d76c2ba6034f15a3cc5221b0379d758c00fffe0a16d4')
+_gitname="dashticz_v2"
+
+pkgver() {
+ cd $_gitname
+ echo -e "$pkgver\c" | sed -e 's/\..*//'
+ echo ".r"$(git log | wc -l)
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/domoticz/www/dashboard"
+ cp -r $_gitname/* "${pkgdir}/opt/domoticz/www/dashboard/"
+ chown -R http:http "${pkgdir}/opt/domoticz/www"
+}
diff --git a/dashticz.install b/dashticz.install
new file mode 100644
index 000000000000..b916dcc43d91
--- /dev/null
+++ b/dashticz.install
@@ -0,0 +1,8 @@
+post_install() {
+ chown -R http:http "${pkgdir}/opt/domoticz/www/dashboard"
+ echo "After the installation is finished, go to the /domoticz/www/<dashticzv2 folder>/custom/ folder, copy the CONFIG_DEFAULT.js file to CONFIG.js (mind the CAPITALS!).
+
+cd domoticz/www/<dashticzv2 folder>/custom/
+cp CONFIG_DEFAULT.js CONFIG.js"
+}
+