summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2017-12-14 22:48:18 +0800
committeredward-p2017-12-14 22:48:18 +0800
commitb9beabb15880f1230a828ba96da66ae7d947a1ed (patch)
treeeca2c1ba854c7aba9b09fb71e36964d4d11d3ac3
downloadaur-b9beabb15880f1230a828ba96da66ae7d947a1ed.tar.gz
packaged
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--ttf-consolas-with-yahei.install11
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0809229fd96f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-consolas-with-yahei
+ pkgdesc = Consolas-with-Yahei is a hybrid font(add CJK characters from MS-Yahei to Consolas)
+ pkgver = 0.1.1
+ pkgrel = 0
+ url = https://github.com/edward-p/Consolas-with-Yahei
+ install = ttf-consolas-with-yahei.install
+ arch = any
+ makedepends = tar
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/edward-p/Consolas-with-Yahei/releases/download/v0.1.1/consya.tar.xz
+ md5sums = 7b018121106df894cde2522c32dc6c0b
+
+pkgname = ttf-consolas-with-yahei
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560da77c1f7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: edward-p <micro.fedora@gmail.com>
+pkgname=ttf-consolas-with-yahei
+pkgver='0.1.1'
+pkgrel=0
+pkgdesc="Consolas-with-Yahei is a hybrid font(add CJK characters from MS-Yahei to Consolas)"
+arch=(any)
+url=https://github.com/edward-p/Consolas-with-Yahei
+depends=(fontconfig xorg-font-utils)
+makedepends=(tar)
+fontname='consolas-with-yahei'
+source=("https://github.com/edward-p/Consolas-with-Yahei/releases/download/v$pkgver/consya.tar.xz")
+md5sums=('7b018121106df894cde2522c32dc6c0b')
+install=$pkgname.install
+prepare() {
+ tar -xvf consya.tar.xz
+}
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/$fontname
+ chmod -R 755 "$pkgdir"/usr/
+ cp $srcdir/consya.ttf "$pkgdir"/usr/share/fonts/$fontname/consya.ttf
+ cp $srcdir/consyab.ttf "$pkgdir"/usr/share/fonts/$fontname/consyab.ttf
+ cp $srcdir/consyai.ttf "$pkgdir"/usr/share/fonts/$fontname/consyai.ttf
+ cp $srcdir/consyaz.ttf "$pkgdir"/usr/share/fonts/$fontname/consyaz.ttf
+}
diff --git a/ttf-consolas-with-yahei.install b/ttf-consolas-with-yahei.install
new file mode 100644
index 000000000000..222aaa8e0a8f
--- /dev/null
+++ b/ttf-consolas-with-yahei.install
@@ -0,0 +1,11 @@
+post_install() {
+ fc-cache -s
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}