summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJochen Jägers2019-10-26 14:44:48 +0200
committerJochen Jägers2019-10-26 14:44:48 +0200
commitb9ede84ad7b95619edb63e0e96b6dc228cb0dae1 (patch)
tree4c730690adbcc5b819f61a382f4cb94acaf0b019
parent49ae7833994e07bb4a98e486e59fa1010fb7b7fb (diff)
downloadaur-b9ede84ad7b95619edb63e0e96b6dc228cb0dae1.tar.gz
updated to 0.8.1.1702.bc0dc57
-rw-r--r--.SRCINFO4
-rw-r--r--0001-migrated-SConstrcut-from-python2-to-python3.patch118
-rw-r--r--PKGBUILD15
3 files changed, 133 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41e47fb26f05..f4ed4aab9f12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = websocketpp-git-dev
pkgdesc = C++/Boost Asio based websocket client/server library, Develop branch
- pkgver = 0.7.0.1685.19cad99
+ pkgver = 0.8.1.1702.bc0dc57
pkgrel = 1
url = http://www.zaphoyd.com/websocketpp/
arch = any
@@ -17,7 +17,9 @@ pkgbase = websocketpp-git-dev
provides = websocketpp
conflicts = websocketpp
source = websocketpp-git-dev::git+https://github.com/zaphoyd/websocketpp#branch=develop
+ source = 0001-migrated-SConstrcut-from-python2-to-python3.patch
sha512sums = SKIP
+ sha512sums = 6e3081c6857599e83179200c0a2096760e3d6903e4ca4bf45acd66460921f84d8934ec8e73062ef3a53948514a8eaf3a5e658d370c716b1b4ef0ff60d0c43eaa
pkgname = websocketpp-git-dev
diff --git a/0001-migrated-SConstrcut-from-python2-to-python3.patch b/0001-migrated-SConstrcut-from-python2-to-python3.patch
new file mode 100644
index 000000000000..cd2a4545a01b
--- /dev/null
+++ b/0001-migrated-SConstrcut-from-python2-to-python3.patch
@@ -0,0 +1,118 @@
+From 812c9ff669553065520c47e51477fcd81cb102d2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jochen=20J=C3=A4gers?= <jochen.jaegers@riedel-at.de>
+Date: Sat, 26 Oct 2019 14:21:31 +0200
+Subject: [PATCH] migrated SConstrcut from python2 to python3
+
+---
+ SConstruct | 39 ++++++++++++++++++++-------------------
+ 1 file changed, 20 insertions(+), 19 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index ae3df10..4fd3876 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1,18 +1,19 @@
+-import os, sys, commands
++import os, sys, subprocess, SCons.Errors
++
+ env = Environment(ENV = os.environ)
+
+ # figure out a better way to configure this
+-if os.environ.has_key('CXX'):
++if 'CXX' in os.environ:
+ env['CXX'] = os.environ['CXX']
+
+-if os.environ.has_key('DEBUG'):
++if 'DEBUG' in os.environ:
+ env['DEBUG'] = os.environ['DEBUG']
+
+-if os.environ.has_key('CXXFLAGS'):
++if 'CXXFLAGS' in os.environ:
+ #env['CXXFLAGS'] = os.environ['CXXFLAGS']
+ env.Append(CXXFLAGS = os.environ['CXXFLAGS'])
+
+-if os.environ.has_key('LINKFLAGS'):
++if 'LINKFLAGS' in os.environ:
+ #env['LDFLAGS'] = os.environ['LDFLAGS']
+ env.Append(LINKFLAGS = os.environ['LINKFLAGS'])
+
+@@ -22,24 +23,24 @@ if os.environ.has_key('LINKFLAGS'):
+ ## or set BOOST_INCLUDES and BOOST_LIBS if Boost comes with your OS distro e.g. and
+ ## needs BOOST_INCLUDES=/usr/include/boost and BOOST_LIBS=/usr/lib like Ubuntu.
+ ##
+-if os.environ.has_key('BOOSTROOT'):
++if 'BOOSTROOT' in os.environ:
+ os.environ['BOOST_ROOT'] = os.environ['BOOSTROOT']
+
+-if os.environ.has_key('BOOST_ROOT'):
++if 'BOOST_ROOT' in os.environ:
+ env['BOOST_INCLUDES'] = os.environ['BOOST_ROOT']
+ env['BOOST_LIBS'] = os.path.join(os.environ['BOOST_ROOT'], 'stage', 'lib')
+-elif os.environ.has_key('BOOST_INCLUDES') and os.environ.has_key('BOOST_LIBS'):
++elif 'BOOST_INCLUDES' in os.environ and 'BOOST_LIBS' in os.environ:
+ env['BOOST_INCLUDES'] = os.environ['BOOST_INCLUDES']
+ env['BOOST_LIBS'] = os.environ['BOOST_LIBS']
+ else:
+- raise SCons.Errors.UserError, "Neither BOOST_ROOT, nor BOOST_INCLUDES + BOOST_LIBS was set!"
++ raise SCons.Errors.UserError("Neither BOOST_ROOT, nor BOOST_INCLUDES + BOOST_LIBS was set!")
+
+ ## Custom OpenSSL
+-if os.environ.has_key('OPENSSL_PATH'):
++if 'OPENSSL_PATH' in os.environ:
+ env.Append(CPPPATH = os.path.join(os.environ['OPENSSL_PATH'], 'include'))
+ env.Append(LIBPATH = os.environ['OPENSSL_PATH'])
+
+-if os.environ.has_key('WSPP_ENABLE_CPP11'):
++if 'WSPP_ENABLE_CPP11' in os.environ:
+ env['WSPP_ENABLE_CPP11'] = True
+ else:
+ env['WSPP_ENABLE_CPP11'] = False
+@@ -84,7 +85,7 @@ elif env['PLATFORM'] == 'posix':
+ env.Append(CCFLAGS = ['-Wall'])
+ #env['LINKFLAGS'] = ''
+ elif env['PLATFORM'] == 'darwin':
+- if not os.environ.has_key('CXX'):
++ if not 'CXX' in os.environ:
+ env['CXX'] = "clang++"
+ if env.has_key('DEBUG'):
+ env.Append(CCFLAGS = ['-g', '-O0'])
+@@ -157,29 +158,29 @@ env_cpp11 = env.Clone ()
+
+ if env_cpp11['CXX'].startswith('g++'):
+ # TODO: check g++ version
+- GCC_VERSION = commands.getoutput(env_cpp11['CXX'] + ' -dumpversion')
++ GCC_VERSION = subprocess.check_output([env_cpp11['CXX'], '-dumpversion']).decode("utf-8")
+
+ if GCC_VERSION > "4.4.0":
+- print "C++11 build environment partially enabled"
++ print("C++11 build environment partially enabled")
+ env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x'],TOOLSET = ['g++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
+ else:
+- print "C++11 build environment is not supported on this version of G++"
++ print("C++11 build environment is not supported on this version of G++")
+ elif env_cpp11['CXX'].startswith('clang++'):
+- print "C++11 build environment enabled"
++ print("C++11 build environment enabled")
+ env.Append(CXXFLANGS = ['-stdlib=libc++'],LINKFLAGS=['-stdlib=libc++'])
+ env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x','-stdlib=libc++'],LINKFLAGS = ['-stdlib=libc++'],TOOLSET = ['clang++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
+
+ # look for optional second boostroot compiled with clang's libc++ STL library
+ # this prevents warnings/errors when linking code built with two different
+ # incompatible STL libraries.
+- if os.environ.has_key('BOOST_ROOT_CPP11'):
++ if 'BOOST_ROOT_CPP11' in os.environ:
+ env_cpp11['BOOST_INCLUDES'] = os.environ['BOOST_ROOT_CPP11']
+ env_cpp11['BOOST_LIBS'] = os.path.join(os.environ['BOOST_ROOT_CPP11'], 'stage', 'lib')
+- elif os.environ.has_key('BOOST_INCLUDES_CPP11') and os.environ.has_key('BOOST_LIBS_CPP11'):
++ elif 'BOOST_INCLUDES_CPP11' in os.environ and 'BOOST_LIBS_CPP11' in os.environ:
+ env_cpp11['BOOST_INCLUDES'] = os.environ['BOOST_INCLUDES_CPP11']
+ env_cpp11['BOOST_LIBS'] = os.environ['BOOST_LIBS_CPP11']
+ else:
+- print "C++11 build environment disabled"
++ print("C++11 build environment disabled")
+
+ # if the build system is known to allow the isystem modifier for library include
+ # values then use it for the boost libraries. Otherwise just add them to the
+--
+2.23.0
+
diff --git a/PKGBUILD b/PKGBUILD
index aefdcc557421..ff4dc3e509d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
+# Maintainer: Jochen Jägers (JochenJ) <aur@diezonks.de>
+# Contributor: boteium <me@hamal.in>
+
pkgname=websocketpp-git-dev
_gitname=websocketpp
-pkgver=0.7.0.1685.19cad99
+pkgver=0.8.1.1702.bc0dc57
pkgrel=1
pkgdesc='C++/Boost Asio based websocket client/server library, Develop branch'
url='http://www.zaphoyd.com/websocketpp/'
@@ -15,8 +18,9 @@ optdepends=(
makedepends=('git' 'cmake' 'boost' 'boost-libs' 'scons')
provides=('websocketpp')
conflicts=('websocketpp')
-source=(${pkgname}::git+https://github.com/zaphoyd/${_gitname}#branch=develop)
-sha512sums=('SKIP')
+source=(${pkgname}::git+https://github.com/zaphoyd/${_gitname}#branch=develop '0001-migrated-SConstrcut-from-python2-to-python3.patch')
+sha512sums=('SKIP'
+ '6e3081c6857599e83179200c0a2096760e3d6903e4ca4bf45acd66460921f84d8934ec8e73062ef3a53948514a8eaf3a5e658d370c716b1b4ef0ff60d0c43eaa')
pkgver() {
cd ${pkgname}
@@ -24,6 +28,11 @@ pkgver() {
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd ${pkgname}
+ patch --forward --strip=1 --input="${srcdir}/0001-migrated-SConstrcut-from-python2-to-python3.patch"
+}
+
build() {
cd ${pkgname}
WSPP_ENABLE_CPP11=1 \