summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerhaeuser2015-12-20 21:13:36 +0100
committerMichael Gerhaeuser2015-12-20 21:13:36 +0100
commitba00eed39a21b1cd4afd70240fbda651f4d57182 (patch)
tree518027763316f652c4b5712122b92f9764ac0135
parent1bf4b169394b9162077f5982aebff911008e66c5 (diff)
downloadaur-ba00eed39a21b1cd4afd70240fbda651f4d57182.tar.gz
Add patch to fix segfault when exiting lua
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--wxlstate.patch14
3 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06ec533527a7..9ebdd7d8542a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Dec 20 19:51:33 UTC 2015
pkgbase = wxlua-svn
pkgdesc = A set of bindings to the wxWidgets library for the Lua programming language - svn version
pkgver = 251
- pkgrel = 1
+ pkgrel = 2
url = http://wxlua.sourceforge.net
install = wxlua.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 9d492c912be7..9b9309073914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=wxlua-svn
_pkgname=wxlua
pkgver=251
-pkgrel=1
+pkgrel=2
pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language - svn version"
arch=('i686' 'x86_64')
url="http://wxlua.sourceforge.net"
@@ -30,6 +30,9 @@ build() {
# wxstedit doc folder fix
sed -i 's|doc/|share/&|' modules/wxstedit/CMakeLists.txt
+ # fix segfault
+ svn patch ../../../wxlstate.patch
+
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
diff --git a/wxlstate.patch b/wxlstate.patch
new file mode 100644
index 000000000000..0e631d5d3779
--- /dev/null
+++ b/wxlstate.patch
@@ -0,0 +1,14 @@
+Index: modules/wxlua/wxlstate.cpp
+===================================================================
+--- modules/wxlua/wxlstate.cpp (revision 251)
++++ modules/wxlua/wxlstate.cpp (working copy)
+@@ -404,6 +404,9 @@
+ if ((m_lua_State == NULL) || m_wxlStateData->m_is_closing || m_lua_State_coroutine)
+ return true;
+
++ if (lua_status(m_lua_State) != LUA_OK)
++ return true;
++
+ m_wxlStateData->m_is_closing = true;
+
+ //wxCHECK_MSG(m_lua_State, false, wxT("Interpreter not created"));