summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:29:24 +0100
committerXZS2016-10-31 18:29:24 +0100
commitba03b75cfa688f49a612a7642fd85c6d35271afa (patch)
tree7e7e2a9dc558280e7134c307a7ec7ce2ce776bd9
parent8830cacc9cebb138de435166c34ff44ec3773503 (diff)
downloadaur-ba03b75cfa688f49a612a7642fd85c6d35271afa.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3944caa235b..02a3821ca111 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozilla-extension-gnotifier
pkgdesc = Add-on for Firefox and Thunderbird. Replaces built-in notifications with the OS native notifications. It
pkgver = 1.9.7
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/mozilla/addon/gnotifier/
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 7e20eb0a3744..affc47912d79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mozilla-extension-gnotifier
pkgver=1.9.7
-pkgrel=1
+pkgrel=2
pkgdesc='Add-on for Firefox and Thunderbird. Replaces built-in notifications with the OS native notifications. It'
arch=('any')
license=('GPL3')
@@ -68,9 +68,18 @@ for target in "${optdepends[@]}"; do
done
optdepends=()
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {