aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-06-13 19:07:35 -0400
committerAntony Kellermann2018-06-13 19:07:35 -0400
commitba3d1f6a62388284f1be79e890a97ad97957ef16 (patch)
tree17893f9703f13a83d0437d3d3916058f0888c392
parent20cccf5cc48dbaaf32142d375cfd5d5cf15aba4c (diff)
downloadaur-ba3d1f6a62388284f1be79e890a97ad97957ef16.tar.gz
New version: 2.4.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--README.md9
-rw-r--r--tick.16
4 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa794ea32d4f..db7be60bfbd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tick
pkgdesc = Command line stock and cryptocurrency portfolio tracker.
- pkgver = 2.3.0
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/aokellermann/tick
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index bffd91692dfe..35da4046597c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antony Kellermann <aokellermann@gmail.com>
pkgname=tick
-pkgver=2.3.0
+pkgver=2.4.0
pkgrel=1
pkgdesc="Command line stock and cryptocurrency portfolio tracker."
arch=('x86_64')
@@ -15,6 +15,7 @@ md5sums=('SKIP')
build() {
cd "$srcdir/$pkgname"
+ git checkout $(git rev-list --tags --max-count=1) # Checks out latest tag instead of latest commit
CPPFLAGS="$CPPFLAGS -O2"
make
}
diff --git a/README.md b/README.md
index fcfe233b7eed..e83c03f00f1b 100644
--- a/README.md
+++ b/README.md
@@ -42,8 +42,9 @@ $ tick check
Prints information about all of your current holdings and a grand total
in an NCurses window. By default, your holdings will be sorted
alphabetically. You may press the left and right arrow keys to change
-the sort category. Press "q" to exit the window. You can also get
-information on a specific security using
+the sort category, or up and down to highlight different securities.
+Press "q" to exit the window. You can also get information on a specific
+security using
```bash
$ tick check [symbol/crypto_id/USD$]
```
@@ -115,4 +116,6 @@ and portfolio distribution (tried to implement, but IEX API is unpredictable; wa
* Average graph points when skipping indices for greater accuracy
* Android app?
* GUI?
-* Competitor information \ No newline at end of file
+* Index support (djia, sp500)
+* History stack
+* Exit if window is resized to too small \ No newline at end of file
diff --git a/tick.1 b/tick.1
index 4b7d1edcc02c..f790e2491b41 100644
--- a/tick.1
+++ b/tick.1
@@ -1,4 +1,4 @@
-.TH TICK "1" "June 2018" "Tick 2.3.0" "User Commands"
+.TH TICK "1" "June 2018" "Tick 2.4.0" "User Commands"
.SH NAME
Tick - Command line stock and cryptocurrency portfolio tracker.
@@ -28,8 +28,8 @@ You may also specify the share price instead of the total amount you spent by ap
.TP
[check]
Prints information about all of your current holdings and a grand total in an NCurses window. By default, your holdings
-will be sorted alphabetically. You may press the left and right arrow keys to change the sort category. Press "q" to
-exit the window.
+will be sorted alphabetically. You may press the left and right arrow keys to change the sort category. The up and
+down arrow keys may be used to scroll up and down the list and highlight securities. Press "q" to exit the window.
.TP
[check] [symbol/crypto_id/USD$]