summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMvdS2017-12-18 11:00:13 +0100
committerMvdS2017-12-18 11:00:13 +0100
commitba434683b40ec4ba94f772a6e6d9998050a3e39b (patch)
tree35f3ae193222d8cf4114a043a93df537df29cd8a
downloadaur-ba434683b40ec4ba94f772a6e6d9998050a3e39b.tar.gz
Initial PKGBUILD for han-ese-ops_rpi v0.1
-rw-r--r--.SRCINFO17
-rw-r--r--ChangeLog6
-rw-r--r--PKGBUILD20
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe50b59558ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Dec 18 09:59:33 UTC 2017
+pkgbase = han-ese-ops_rpi
+ pkgdesc = Scripts for the Raspberry Pi for the Final Assignment of HAN ESE OPS.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/han-ese/Arch-RPi
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = python3
+ source = https://github.com/han-ese/Arch-RPi/archive/v0.1.tar.gz
+ sha512sums = d70e5c2a6aff7649b956164876e5e7f7d6005c5e9966882d17245046c23b1f77e8624d72ebe07eaa0118e9ec50bb6df19254e03cb81cefac4d7fb57df7d347af
+
+pkgname = han-ese-ops_rpi
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..ad9ecf077eb0
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,6 @@
+
+ChangeLog for han-ese-ops_rpi PKGBUILD
+https://github.com/han-ese/Arch-RPi
+
+* han-ese-ops_rpi-0.1.0 (2017-12-18 - MvdS)
+ Initial PKGBUILD for han-ese-ops_rpi, to be uploaded to AUR
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..687a82159d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Marc van der Sluys < han [at] vandersluys [dt] nl >
+pkgname=han-ese-ops_rpi
+pkgver=0.1
+pkgrel=1
+pkgdesc="Scripts for the Raspberry Pi for the Final Assignment of HAN ESE OPS."
+arch=('any')
+url="https://github.com/han-ese/Arch-RPi"
+license=('GPL3')
+depends=('bash' 'python3')
+changelog=ChangeLog
+source=("https://github.com/han-ese/Arch-RPi/archive/v${pkgver}.tar.gz")
+sha512sums=('d70e5c2a6aff7649b956164876e5e7f7d6005c5e9966882d17245046c23b1f77e8624d72ebe07eaa0118e9ec50bb6df19254e03cb81cefac4d7fb57df7d347af')
+
+package() {
+ cd Arch-RPi-${pkgver}
+ mkdir -p ${pkgdir}/usr/bin/ ${pkgdir}/usr/lib/systemd/system/
+ cp -vp python/* ${pkgdir}/usr/bin/
+ cp -vp shell/* ${pkgdir}/usr/bin/
+ cp -vp systemd/* ${pkgdir}/usr/lib/systemd/system/
+}