summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-09-02 07:27:20 -0600
committerMark Wagie2020-09-02 07:27:20 -0600
commitba48772ae3f0ce4bfabbc971d3f55edf806b9de5 (patch)
treed3faa3ca82182417bfc9fd2394b4ac3fba9f9637
parenta57a9c9bde04fd712388f6f7d01548a013ffe584 (diff)
downloadaur-ba48772ae3f0ce4bfabbc971d3f55edf806b9de5.tar.gz
0.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac041b9521aa..ddf88867305a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blanket
pkgdesc = Improve focus and increase your productivity by listening to different sounds.
- pkgver = 0.1.0+11+g208c67a
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/rafaelmardojai/blanket
arch = x86_64
@@ -9,9 +9,9 @@ pkgbase = blanket
depends = gtk3
depends = gst-python
depends = python-gobject
- depends = libhandy
- source = git+https://github.com/rafaelmardojai/blanket.git#commit=208c67a5687a471b74978f63943f83ffb61600b0
- sha256sums = SKIP
+ depends = libhandy1
+ source = blanket-0.2.0.tar.gz::https://github.com/rafaelmardojai/blanket/archive/0.2.0.tar.gz
+ sha256sums = 74469e0f1fefff877414f09e43a94f272afe0913134afd95ba1052647db3728c
pkgname = blanket
diff --git a/PKGBUILD b/PKGBUILD
index 07eac97d5cc9..583a688fb64b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,18 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=blanket
-pkgver=0.1.0+11+g208c67a
+pkgver=0.2.0
pkgrel=1
pkgdesc="Improve focus and increase your productivity by listening to different sounds."
arch=('x86_64')
url="https://github.com/rafaelmardojai/blanket"
license=('GPL3')
-depends=('gtk3' 'gst-python' 'python-gobject' 'libhandy')
+depends=('gtk3' 'gst-python' 'python-gobject' 'libhandy1')
makedepends=('meson')
-_commit=208c67a5687a471b74978f63943f83ffb61600b0
-source=("git+https://github.com/rafaelmardojai/blanket.git#commit=$_commit")
-sha256sums=('SKIP')
-#source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-#sha256sums=('b67d887975bbfa766e5e831cd7667b3e45359399c875b5717eb071b7ab526935')
-
-pkgver() {
- cd "$srcdir/$pkgname"
- git describe --tags | sed 's/-/+/g'
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('74469e0f1fefff877414f09e43a94f272afe0913134afd95ba1052647db3728c')
build() {
- arch-meson "$pkgname" build
+ arch-meson "$pkgname-$pkgver" build
meson compile -C build
}