summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Klevtsov2021-10-06 10:26:50 +0700
committerArtem Klevtsov2021-10-06 10:26:50 +0700
commitba56e79718d39dd0f9199c1ce1377d1d458c3681 (patch)
treef95f4fbc24da25253f8c81afddacf8a527ed9211
parent30a705005aa9f8eb0668b454761efb14b370e87a (diff)
downloadaur-ba56e79718d39dd0f9199c1ce1377d1d458c3681.tar.gz
Remove unneeded patches
-rw-r--r--rstudio_boost.patch25
-rw-r--r--soci.patch59
2 files changed, 0 insertions, 84 deletions
diff --git a/rstudio_boost.patch b/rstudio_boost.patch
deleted file mode 100644
index 10ffa194e5ba..000000000000
--- a/rstudio_boost.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6511e6ce3fef2fe628cbb436e30289829351f088 Mon Sep 17 00:00:00 2001
-From: Stephen Martin <stephensrmmartin@gmail.com>
-Date: Tue, 31 Mar 2020 16:30:47 -0700
-Subject: [PATCH] Use boost, not rstudio_boost
-
----
- src/cpp/server_core/ServerDatabase.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cpp/server_core/ServerDatabase.cpp b/src/cpp/server_core/ServerDatabase.cpp
-index ad04faadb1..1ba5771076 100644
---- a/src/cpp/server_core/ServerDatabase.cpp
-+++ b/src/cpp/server_core/ServerDatabase.cpp
-@@ -199,7 +199,7 @@ boost::shared_ptr<IConnection> getConnection()
- return s_connectionPool->getConnection();
- }
-
--bool getConnection(const rstudio_boost::posix_time::time_duration& waitTime,
-+bool getConnection(const boost::posix_time::time_duration& waitTime,
- boost::shared_ptr<IConnection>* pConnection)
- {
- return s_connectionPool->getConnection(waitTime, pConnection);
---
-2.26.0
-
diff --git a/soci.patch b/soci.patch
deleted file mode 100644
index 8b9013c73c38..000000000000
--- a/soci.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 40f01db1d748d5df0bc3dfd1552a2c91943408e7 Mon Sep 17 00:00:00 2001
-From: Stephen Martin <stephensrmmartin@gmail.com>
-Date: Tue, 31 Mar 2020 14:55:34 -0700
-Subject: [PATCH] Use system SOCI library on request.
-
----
- src/cpp/CMakeLists.txt | 15 ++++++++++-----
- 1 file changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
-index 9fff318025..598f34fd87 100644
---- a/src/cpp/CMakeLists.txt
-+++ b/src/cpp/CMakeLists.txt
-@@ -372,8 +372,10 @@ else()
- endif()
-
- set(SOCI_INCLUDE_DIR "${RSTUDIO_TOOLS_SOCI}/include")
--include_directories(SYSTEM ${SOCI_INCLUDE_DIR})
--include_directories(SYSTEM ${SOCI_INCLUDE_BUILD_DIR})
-+if(NOT RSTUDIO_USE_SYSTEM_SOCI)
-+ include_directories(SYSTEM ${SOCI_INCLUDE_DIR})
-+ include_directories(SYSTEM ${SOCI_INCLUDE_BUILD_DIR})
-+endif()
-
- # database library includes
- if (UNIX)
-@@ -394,6 +396,9 @@ endif()
- # find SOCI libraries
- if(UNIX)
- set(SOCI_LIBRARY_DIR "${RSTUDIO_TOOLS_SOCI}/build/lib")
-+ if(NOT APPLE AND RSTUDIO_USE_SYSTEM_SOCI)
-+ set(SOCI_LIBRARY_DIR "/usr/lib")
-+ endif()
- set(CMAKE_INSTALL_RPATH "${SOCI_LIBRARY_DIR}")
- if (NOT APPLE)
- set(LIB_SUFFIX ".so")
-@@ -404,8 +409,8 @@ if(UNIX)
- set(SOCI_LIB_SYMLINK ".4.0${LIB_SUFFIX}")
- set(SOCI_LIB_SUFFIX ".4.0.0${LIB_SUFFIX}")
- endif()
-- file(GLOB_RECURSE SOCI_LIBRARIES "${SOCI_LIBRARY_DIR}/*${LIB_SUFFIX}")
-- file(GLOB_RECURSE SOCI_SYMLINK_LIBRARIES "${SOCI_LIBRARY_DIR}/*${SOCI_LIB_SYMLINK}")
-+ file(GLOB_RECURSE SOCI_LIBRARIES "${SOCI_LIBRARY_DIR}/*soci*${LIB_SUFFIX}")
-+ file(GLOB_RECURSE SOCI_SYMLINK_LIBRARIES "${SOCI_LIBRARY_DIR}/*soci*${SOCI_LIB_SYMLINK}")
- else()
- set(SOCI_LIBRARY_DIR "${RSTUDIO_TOOLS_SOCI}/build/${SOCI_ARCH}/lib")
- if(CMAKE_BUILD_TYPE STREQUAL "Debug")
-@@ -436,7 +441,7 @@ message(STATUS "SOCI libraries found under ${SOCI_LIBRARY_DIR}.")
-
- # ensure the soci libraries are installed with the installation package on Linux
- # on OSX, the needed depdencies are copied into the Frameworks directory
--if(UNIX AND NOT APPLE)
-+if(UNIX AND NOT APPLE AND NOT RSTUDIO_USE_SYSTEM_SOCI)
- install(PROGRAMS "${SOCI_LIBRARY_DIR}/libsoci_core${SOCI_LIB_SUFFIX}" DESTINATION ${RSTUDIO_INSTALL_BIN})
- install(PROGRAMS "${SOCI_LIBRARY_DIR}/libsoci_sqlite3${SOCI_LIB_SUFFIX}" DESTINATION ${RSTUDIO_INSTALL_BIN})
- install(PROGRAMS "${SOCI_LIBRARY_DIR}/libsoci_postgresql${SOCI_LIB_SUFFIX}" DESTINATION ${RSTUDIO_INSTALL_BIN})
---
-2.26.0
-