summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2021-09-20 20:55:22 +1200
committerVaporeon2021-09-20 20:55:22 +1200
commitba5ee02bb166e21a93c947ff497f34979454652b (patch)
tree09ca458c3ac4538104cad5896a996b4aa3179647
parent2d8b151aebfc197ade538d1e71d384995f28eba4 (diff)
downloadaur-ba5ee02bb166e21a93c947ff497f34979454652b.tar.gz
Install systems.cfg and always build menu.bin (do we really want this?)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--menu.patch23
3 files changed, 11 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57ca50fcb08..c93d7ff72b81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = blastem-hg
pkgdesc = Fast and accurate Sega Genesis/Mega Drive emulator
- pkgver = r2024.ba5d206dcfea
+ pkgver = r2040.a61b47d5489e
pkgrel = 1
url = http://rhope.retrodev.com/files/blastem.html
arch = x86_64
license = GPLv3
makedepends = mercurial
makedepends = python2-pillow
+ makedepends = vasm
+ makedepends = xcftools
depends = sdl2
depends = glew
provides = blastem
@@ -14,7 +16,6 @@ pkgbase = blastem-hg
source = blastem::hg+http://rhope.retrodev.com/repos/blastem
source = menu.patch
sha256sums = SKIP
- sha256sums = 4b8e76103e1d607f2e4117c1a23e1d97b2bdca5f01ac2b5d3b433478a3b211d6
+ sha256sums = 9c5a6b77b20c221bdbd1f274d3ace8ed25bdc5678840c4985acc605d43203af5
pkgname = blastem-hg
-
diff --git a/PKGBUILD b/PKGBUILD
index 50e46840cf1b..1b7afdabf053 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Vaporeon <vaporeon@vaporeon.io>
# Contributor: Lukas Sabota <lukas@lwsabota.com>
pkgname=blastem-hg
-pkgver=r2024.ba5d206dcfea
+pkgver=r2040.a61b47d5489e
pkgrel=1
pkgdesc="Fast and accurate Sega Genesis/Mega Drive emulator"
arch=('x86_64')
url="http://rhope.retrodev.com/files/blastem.html"
license=('GPLv3')
depends=('sdl2' 'glew')
-makedepends=('mercurial' 'python2-pillow')
+makedepends=('mercurial' 'python2-pillow' 'vasm' 'xcftools')
provides=('blastem')
conflicts=('blastem')
source=(blastem::hg+http://rhope.retrodev.com/repos/blastem
'menu.patch')
sha256sums=('SKIP'
- '4b8e76103e1d607f2e4117c1a23e1d97b2bdca5f01ac2b5d3b433478a3b211d6')
+ '9c5a6b77b20c221bdbd1f274d3ace8ed25bdc5678840c4985acc605d43203af5')
pkgver() {
cd $srcdir/${pkgname%-hg}
@@ -24,27 +24,25 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-hg}"
patch -Np1 -i "${srcdir}/menu.patch"
- chmod a+x menumake.sh install.sh
- #GCC10 workaround
- perl -pi -e 's|(CFLAGS:=)(-std=gnu99.*)|\1-fcommon \2|g' Makefile
}
build() {
cd "$srcdir/${pkgname%-hg}"
make blastem
- ./menumake.sh
+ make menu.bin
}
package() {
cd "$srcdir/${pkgname%-hg}"
- ./install.sh
mkdir -p "$pkgdir/opt/blastem"
install -d -g games "$pkgdir/opt/blastem"
- install -m 755 -g games -D to_install/* "$pkgdir/opt/blastem"
+ install -m 755 -g games -D blastem "$pkgdir/opt/blastem"
install -m 666 -g games -D default.cfg "$pkgdir/opt/blastem"
+ install -m 666 -g games -D systems.cfg "$pkgdir/opt/blastem"
install -m 666 -g games rom.db gamecontrollerdb.txt "$pkgdir/opt/blastem"
install -m 644 -g games -d "$pkgdir/opt/blastem/shaders"
install -m 644 -g games -D shaders/* "$pkgdir/opt/blastem/shaders"
+ install -m 644 -g games -D menu.bin "$pkgdir/opt/blastem"
chmod 755 "$pkgdir/opt/blastem/blastem"
chown root:games "$pkgdir/opt/blastem"
chown root:games "$pkgdir/opt/blastem/shaders"
diff --git a/menu.patch b/menu.patch
index d12b760c7d59..20eb86e0c62e 100644
--- a/menu.patch
+++ b/menu.patch
@@ -7,26 +7,3 @@ diff -Nura blastem.old/img2tiles.py blastem.new/img2tiles.py
from PIL import Image
def gchannel(Val):
-diff -Nura blastem.old/install.sh blastem.new/install.sh
---- blastem.old/install.sh 1969-12-31 21:00:00.000000000 -0300
-+++ blastem.new/install.sh 2017-06-08 00:50:40.403699591 -0300
-@@ -0,0 +1,5 @@
-+mkdir "to_install"
-+cp blastem to_install/blastem
-+if [ -f "./menu.bin" ]; then
-+ cp menu.bin to_install/menu.bin
-+fi
-diff -Nura blastem.old/menumake.sh blastem.new/menumake.sh
---- blastem.old/menumake.sh 1969-12-31 21:00:00.000000000 -0300
-+++ blastem.new/menumake.sh 2017-06-08 00:52:01.067033096 -0300
-@@ -0,0 +1,10 @@
-+#!/bin/bash
-+if(pacman -Q vasm >/dev/null); then
-+ if(pacman -Q xcftools >/dev/null); then
-+ make menu.bin
-+ else
-+ echo "You need to install vasm and xcftools from AUR to compile the menu"
-+ fi
-+else
-+ echo "You need to install vasm and xcftools from AUR to compile the menu"
-+fi