summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2017-04-20 17:59:07 -0600
committeramagura2017-04-20 17:59:07 -0600
commitba63cb45f6762cbe43a78ab63ad9a04018f2227a (patch)
tree9aa285b4273011cc612e028142b4ce63523b593b
downloadaur-ba63cb45f6762cbe43a78ab63ad9a04018f2227a.tar.gz
well, here`s an alpha package at any rate
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
-rw-r--r--bin32-epsxe.desktop10
-rw-r--r--bin32-epsxe.install17
-rw-r--r--bin32-epsxe.pngbin0 -> 757 bytes
-rw-r--r--bin32-epsxe.sh4
6 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e1382531e78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Apr 20 23:58:55 UTC 2017
+pkgbase = bin32-epsxe
+ pkgdesc = Enhanced PSX emulator (32-bit)
+ pkgver = 2.0.5
+ pkgrel = 1
+ url = http://epsxe.com
+ install = bin32-epsxe.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = gtk3
+ depends = sdl_ttf
+ depends = libtinfo
+ depends = libcurl-compat
+ options = !strip
+ source = bin32-epsxe.desktop
+ source = bin32-epsxe.png
+ source = bin32-epsxe.sh
+ source = http://www.epsxe.com/files/ePSXe205linux.zip
+ md5sums = aeb34e2ca34f968630ca133ea821c61c
+ md5sums = eb0c46b8ae1355c589792f6be1835e47
+ md5sums = 071c43c1cb8f6b6470b7af60ad69247a
+ md5sums = 3e1976822eb260722b31c9f24cb1d6e1
+
+pkgname = bin32-epsxe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87339cd45fd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Alexej Magura <agm2819*gmail*>
+# Contributor: Swen Simon <swsimon at gmail dot com>
+# Contributor: Raphaƫl Doursenaud <rdoursenaud@gmail.com>
+pkgname=bin32-epsxe
+_pkgname=ePSXe
+pkgver=2.0.5
+pkgrel=1
+pkgdesc="Enhanced PSX emulator (32-bit)"
+url="http://epsxe.com"
+arch=('i686' 'x86_64')
+depends=(gtk3 sdl_ttf libtinfo libcurl-compat)
+license=('unknown')
+install=${pkgname}.install
+options=(!strip)
+source=(${pkgname}.desktop ${pkgname}.png ${pkgname}.sh)
+md5sums=('aeb34e2ca34f968630ca133ea821c61c'
+ 'eb0c46b8ae1355c589792f6be1835e47'
+ '071c43c1cb8f6b6470b7af60ad69247a')
+source+=("http://www.epsxe.com/files/ePSXe${pkgver//./}linux.zip")
+md5sums+=('3e1976822eb260722b31c9f24cb1d6e1')
+
+package()
+{
+ binary="${_pkgname}"
+ cd "${srcdir}"
+ install -d "${pkgdir}"/usr/{share/doc/"${pkgname}",lib}
+
+ find docs -name 'e???e_*.txt' -execdir install -m 644 -t ${pkgdir}/usr/share/doc/${pkgname} \{\} +
+ # find . -name '*.cht' -execdir "install -Dm 644 -t \${pkgdir}/opt/${pkgname}/${pkgver}/cheats\"" \{\} +
+
+
+ install -Dm 755 "${binary}" "${pkgdir}/opt/${pkgname}/${pkgname}"
+# install -Dm 644 keycodes.lst "${pkgdir}/opt/${pkgname}/keycodes.lst"
+
+ cd "${srcdir}"
+ install -Dm 755 ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 644 "${srcdir}/$pkgname.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm 644 "${srcdir}/$pkgname.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ ln -sf "$HOME/.${pkgname}rc" -T "${pkgdir}/opt/${pkgname}/.${pkgname}rc"
+
+ # libtinfo and ncurses crap
+ ln -s /usr/lib32/libncursesw.so.6 "$pkgdir"/opt/"$pkgname"/libncurses.so.5
+ ln -s /usr/lib32/libtinfo.so.6 "$pkgdir"/opt/"$pkgname"/libtinfo.so.5
+}
diff --git a/bin32-epsxe.desktop b/bin32-epsxe.desktop
new file mode 100644
index 000000000000..8bb3944cde4f
--- /dev/null
+++ b/bin32-epsxe.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=ePSXe
+GenericName=ePSXe
+Comment=Enhanced PSX emulator
+Icon=/usr/share/pixmaps/epsxe.png
+#TryExec=/opt/epsxe/epsxe
+Exec=/usr/bin/epsxe
+Terminal=false
+Categories=Game;
diff --git a/bin32-epsxe.install b/bin32-epsxe.install
new file mode 100644
index 000000000000..ef3067f137ec
--- /dev/null
+++ b/bin32-epsxe.install
@@ -0,0 +1,17 @@
+post_install() {
+ cat << EOF
+
+Add your user to group 'games' in order to play.
+
+EOF
+}
+
+#There are launcher packages out for epsxe. Search
+#AUR for epsxe-launcher-* if you want to use it.
+
+#EOF
+#}
+
+op=$1
+shift
+$op $*
diff --git a/bin32-epsxe.png b/bin32-epsxe.png
new file mode 100644
index 000000000000..fdd413a63904
--- /dev/null
+++ b/bin32-epsxe.png
Binary files differ
diff --git a/bin32-epsxe.sh b/bin32-epsxe.sh
new file mode 100644
index 000000000000..6205eb9b980e
--- /dev/null
+++ b/bin32-epsxe.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/env bash
+
+
+LD_LIBRARY_PATH+=:/opt/epsxe LD_PRELOAD=/usr/lib32/libcurl.so.3 /opt/epsxe/epsxe "$@"