summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2022-02-19 12:39:55 +1000
committerAdam Nielsen2022-02-19 12:40:20 +1000
commitba681f1514ea6568c000ee17fda9f79ab17e0283 (patch)
tree7610c757357273d19eb3a6aa8c41595da4fc8378
parent364db4453c9dc8a8380df11522d6534251460c9a (diff)
downloadaur-ba681f1514ea6568c000ee17fda9f79ab17e0283.tar.gz
Switch to upstream systemd/config files
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--smcroute.conf6
-rw-r--r--smcroute.conf.example31
-rw-r--r--smcroute.default2
-rw-r--r--smcroute.service15
6 files changed, 35 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1782585e49d1..4c519784696f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = smcroute
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
pkgver = 2.5.5
- pkgrel = 1
+ pkgrel = 2
url = https://troglobit.com/smcroute.html
arch = i686
arch = x86_64
@@ -12,13 +12,13 @@ pkgbase = smcroute
provides = mcsender
backup = etc/smcroute.conf
source = https://github.com/troglobit/smcroute/releases/download/2.5.5/smcroute-2.5.5.tar.gz
- source = smcroute.conf.example
- source = smcroute.service
+ source = smcroute.conf
+ source = smcroute.default
md5sums = 6ed58b4887ccb737687b584f5794c7ed
- md5sums = 98bdb5bbd222686761e318ee04825b7a
- md5sums = 7b28500642045b2482f5ac873da0f86b
+ md5sums = c230266bb9ba2a0d399f658ec2e46d88
+ md5sums = 5ad63a25952f8b6f368c61111cf15967
sha256sums = 2569cd97fa2047df14203a7144be53a1b32928cb460421a302bbcce381b42bc3
- sha256sums = cd62ffd5ca24d41552591592aaed0448c6e9b379a62b9820851798d68b3cbe1c
- sha256sums = 0d970e38abde99694df7959809e9323ef8d85ed1e62e352b681e325a935a8959
+ sha256sums = f0e3f8651b3b5ba5490a16b5ad21d19a2a641cb61d80742bc0b07ba97eef0b63
+ sha256sums = 92ad598fed09f8b4211f66929b16111f8bc6436d2f0d36d6325f7bf37425f159
pkgname = smcroute
diff --git a/PKGBUILD b/PKGBUILD
index f6d31555327a..4ca2a827fe48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Adam Nielsen <malvineous@shikadi.net>
pkgname=smcroute
pkgver=2.5.5
-pkgrel=1
+pkgrel=2
pkgdesc="A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing."
arch=('i686' 'x86_64')
url="https://troglobit.com/smcroute.html"
@@ -12,14 +12,14 @@ provides=('smcroute' 'mcsender')
backup=('etc/smcroute.conf')
depends=('libcap' 'bash')
source=("https://github.com/troglobit/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
- 'smcroute.conf.example'
- 'smcroute.service')
+ 'smcroute.conf'
+ 'smcroute.default')
md5sums=('6ed58b4887ccb737687b584f5794c7ed'
- '98bdb5bbd222686761e318ee04825b7a'
- '7b28500642045b2482f5ac873da0f86b')
+ 'c230266bb9ba2a0d399f658ec2e46d88'
+ '5ad63a25952f8b6f368c61111cf15967')
sha256sums=('2569cd97fa2047df14203a7144be53a1b32928cb460421a302bbcce381b42bc3'
- 'cd62ffd5ca24d41552591592aaed0448c6e9b379a62b9820851798d68b3cbe1c'
- '0d970e38abde99694df7959809e9323ef8d85ed1e62e352b681e325a935a8959')
+ 'f0e3f8651b3b5ba5490a16b5ad21d19a2a641cb61d80742bc0b07ba97eef0b63'
+ '92ad598fed09f8b4211f66929b16111f8bc6436d2f0d36d6325f7bf37425f159')
build() {
cd $pkgname-$pkgver
@@ -36,10 +36,21 @@ package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
- install -Dm644 "${srcdir}/smcroute.conf.example" "${pkgdir}/etc/smcroute.conf"
- install -Dm644 "${srcdir}/smcroute.service" "${pkgdir}/usr/lib/systemd/system/smcroute.service"
+ # Make our config the main one, so /etc/smcroute.d is used by default.
+ install -Dm644 "${srcdir}/smcroute.conf" "${pkgdir}/etc/smcroute.conf"
+
+ # Put the upstream example config into /etc/smcroute.d but disable it by
+ # ensuring it doesn't match *.conf
+ install -Dm644 "smcroute.conf" "${pkgdir}/etc/smcroute.d/20-main.conf.example"
+
+ # Copy our template for adjusting smcroute command line parameters.
+ install -Dm644 "${srcdir}/smcroute.default" "${pkgdir}/etc/default/smcroute"
+
# nothing useful here
rm -fr "${pkgdir}/usr/share/doc"
+
+ # Remove reference to /usr/share/doc from systemd service.
+ sed -i '/\/usr\/share\/doc/ { D }' "${pkgdir}/usr/lib/systemd/system/smcroute.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/smcroute.conf b/smcroute.conf
new file mode 100644
index 000000000000..786d0e599916
--- /dev/null
+++ b/smcroute.conf
@@ -0,0 +1,6 @@
+# smcroute.conf
+# See smcroute.conf(5) man page.
+
+# Include any snippet in /etc/smcroute.d/, but please remember that
+# all phyint statements must be read first.
+include /etc/smcroute.d/*.conf
diff --git a/smcroute.conf.example b/smcroute.conf.example
deleted file mode 100644
index d8b8d73cd54c..000000000000
--- a/smcroute.conf.example
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# smcroute.conf example
-#
-# The configuration file supports joining multicast groups, to use
-# Layer-2 signaling so that switches and routers open up multicast
-# traffic to your interfaces. Leave is not supported, remove the
-# mgroup and SIGHUP your daemon, or send a specific leave command.
-#
-# Similarily supported is setting mroutes. Removing mroutes is not
-# supported, remove/comment out the mroute or send a remove command.
-#
-# Syntax:
-# mgroup from IFNAME group MCGROUP
-# mroute from IFNAME [source ADDRESS] group MCGROUP to IFNAME [IFNAME ...]
-#
-# The following example instructs the kernel to join the multicast
-# group 225.1.2.3 on interface eth0. Followed by setting up an
-# mroute of the same multicast stream, but from the explicit sender
-# 192.168.1.42 on the eth0 network and forward to eth1 and eth2.
-#
-# mgroup from eth0 group 225.1.2.3
-# mroute from eth0 group 225.1.2.3 source 192.168.1.42 to eth1 eth2
-
-# Here we allow routing of multicast to group 225.3.2.1 from ANY
-# source coming in from interface eth0 and forward to eth1 and eth2.
-# NOTE: Routing from ANY source is currently only available for IPv4
-# multicast.
-#
-# mgroup from eth0 group 225.3.2.1
-# mroute from eth0 group 225.3.2.1 to eth1 eth2
-
diff --git a/smcroute.default b/smcroute.default
new file mode 100644
index 000000000000..25348a1d98d7
--- /dev/null
+++ b/smcroute.default
@@ -0,0 +1,2 @@
+# Extra command line parameters. See smcrouted(8) man page.
+SMCROUTED_OPTS="-l debug"
diff --git a/smcroute.service b/smcroute.service
deleted file mode 100644
index 6d82b4e0a48a..000000000000
--- a/smcroute.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Static Multicast Route Daemon
-After=network.target
-ConditionPathExists=/etc/smcroute.conf
-Conflicts=pimd.service mrouted.service
-
-[Service]
-Type=forking
-PIDFile=/var/run/smcroute.pid
-ExecStart=/usr/bin/smcroute -d
-ExecReload=/bin/kill -HUP $MAINPID
-Restart=on-abort
-
-[Install]
-WantedBy=multi-user.target