summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlockshaw2019-02-04 20:32:20 -0800
committerlockshaw2019-02-04 20:32:20 -0800
commitba69b96af947c75463f7df08cc63f172db59fffa (patch)
tree329b5af7523219239cf08c4bd935414947aa80cf
downloadaur-ba69b96af947c75463f7df08cc63f172db59fffa.tar.gz
Add package for the specific version of z3 angr needs
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ec36a1de232
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-z3-solver-angr
+ pkgdesc = A high-performance theorem prover from Microsoft Research, for use with the angr binary analysis platform
+ pkgver = 4.5.1.0.post2
+ pkgrel = 1
+ url = https://github.com/Z3Prover/z3
+ arch = any
+ license = MIT
+ makedepends = make
+ makedepends = gcc-7
+ makedepends = python-setuptools
+ depends = python
+ provides = python-z3
+ conflicts = python-z3
+ source = python-z3-solver-angr::https://files.pythonhosted.org/packages/source/z/z3-solver/z3-solver-4.5.1.0.post2.tar.gz
+ md5sums = SKIP
+
+pkgname = python-z3-solver-angr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2593b6c20bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Colin Unger <mastakata 3 at yahoo dot com>
+
+pkgname=python-z3-solver-angr
+pkgdesc="A high-performance theorem prover from Microsoft Research, for use with the angr binary analysis platform"
+url="https://github.com/Z3Prover/z3"
+pkgver=4.5.1.0.post2
+pkgrel=1
+arch=('any')
+depends=('python')
+makedepends=('make' 'gcc-7' 'python-setuptools')
+provides=('python-z3')
+conflicts=('python-z3')
+license=('MIT')
+_pypiname=z3-solver
+source=("$pkgname::https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ sed -i 's/gcc/gcc-7/g' "$srcdir/$_pypiname-$pkgver/core/scripts/mk_util.py"
+ sed -i 's/g++/g++-7/g' "$srcdir/$_pypiname-$pkgver/core/scripts/mk_util.py"
+}
+
+build() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 core/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}