summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël Donval2016-09-03 13:24:57 +0200
committerGaël Donval2016-09-03 13:24:57 +0200
commitba6ffec0633de62766ffc6d85d060f15cd7e2b50 (patch)
tree2dc36401f1389c5e9649d0ac93b0cd727a1aed8e
downloadaur-ba6ffec0633de62766ffc6d85d060f15cd7e2b50.tar.gz
initial version: 0.8.0 (in sync with toolz)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f13d21064626
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-cytoolz
+ pkgdesc = A set of utility functions for iterators, functions, and dictionaries.
+ pkgver = 0.8.0
+ pkgrel = 2
+ url = https://github.com/pytoolz
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = cython>=0.17
+ depends = python
+ depends = python-toolz=0.8.0
+ source = https://pypi.org/packages/source/c/cytoolz/cytoolz-0.8.0.tar.gz
+ source = cytoolz_LICENSE::https://github.com/pytoolz/cytoolz/raw/master/LICENSE.txt
+ sha256sums = 2239890c8fe2da3eba82947c6a68cfa406e5a5045911c9ab3de8113462372629
+ sha256sums = SKIP
+
+pkgname = python-cytoolz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98794c23d30a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gaël Donval <gdonval+aur at google mail>
+# Contributor: Gaël Donval <gdonval+aur at google mail>
+
+
+pkgbase='python-cytoolz'
+pkgname='python-cytoolz'
+pkgver=0.8.0
+pkgrel=2
+pkgdesc="A set of utility functions for iterators, functions, and dictionaries."
+arch=('i686' 'x86_64')
+url="https://github.com/pytoolz"
+license=('BSD')
+depends=('python' "python-toolz=$pkgver")
+makedepends=('python-setuptools' 'cython>=0.17')
+source=("https://pypi.org/packages/source/c/cytoolz/cytoolz-${pkgver}.tar.gz"
+ "cytoolz_LICENSE::https://github.com/pytoolz/cytoolz/raw/master/LICENSE.txt")
+sha256sums=('2239890c8fe2da3eba82947c6a68cfa406e5a5045911c9ab3de8113462372629'
+ 'SKIP')
+
+package_python-cytoolz() {
+ install -D -m644 cytoolz_LICENSE "${pkgdir}/usr/share/licenses/python-cytoolz/LICENSE"
+ cd "${srcdir}"/cytoolz-$pkgver
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/python-cytoolz/README"
+}
+
+# vim:ts=2:sw=2:et: