summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Proulx2016-03-30 18:18:09 -0400
committerPhilippe Proulx2016-03-30 18:18:09 -0400
commitba79f4a076c69d33a8a6a16139f2bb8e28d760b7 (patch)
treeacb493a1a003db2a70162070dfa13e02e41c5031
downloadaur-ba79f4a076c69d33a8a6a16139f2bb8e28d760b7.tar.gz
Initial commit: v2.1.4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..938b5e51f70e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Mar 30 22:13:05 UTC 2016
+pkgbase = barectf
+ pkgdesc = Generator of C99 code that can write native CTF out of a YAML configuration file
+ pkgver = 2.1.4
+ pkgrel = 1
+ url = https://github.com/efficios/barectf
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-termcolor
+ depends = python-yaml
+ provides = barectf
+ conflicts = barectf
+ source = https://github.com/efficios/barectf/archive/v2.1.4.tar.gz
+ md5sums = ce698b0849d38f548213c8ce7b960e87
+
+pkgname = barectf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72205988466e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Philippe Proulx <eeppeliteloop@gmail.com>
+pkgname=barectf
+pkgver=2.1.4
+pkgrel=1
+pkgdesc="Generator of C99 code that can write native CTF out of a YAML configuration file"
+arch=('any')
+url='https://github.com/efficios/barectf'
+license=('MIT')
+depends=('python' 'python-termcolor' 'python-yaml')
+makedepends=('python-setuptools')
+provides=('barectf')
+conflicts=('barectf')
+source=("https://github.com/efficios/barectf/archive/v$pkgver.tar.gz")
+md5sums=('ce698b0849d38f548213c8ce7b960e87')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ install -Dm644 "doc/man/barectf.1" "$pkgdir/usr/share/man/man1/barectf.1"
+}