summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2019-03-20 15:45:49 +0100
committerMarc-Olivier Barre2019-03-20 15:45:49 +0100
commitba7a3c784c0e35fce491a4f2cc33307be0298b52 (patch)
tree13e7e80cc241e96f360631463324419cbb4a7b4f
downloadaur-ba7a3c784c0e35fce491a4f2cc33307be0298b52.tar.gz
Initial version of a git package for ocapture
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d3235905e8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = oacapture-git
+ pkgdesc = A planetary imaging application using Qt5
+ pkgver = bb7f8e6
+ pkgrel = 1
+ url = http://www.openastroproject.org/oacapture/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = qt5-base
+ depends = qt5-tools
+ depends = cfitsio
+ depends = autoconf-archive
+ depends = sdl
+ depends = libdc1394
+ optdepends = fxload: support for QHY5 cameras
+ provides = oacapture
+ conflicts = oacapture
+ source = openastro-bb7f8e6::git+https://github.com/openastroproject/openastro#commit=bb7f8e6
+ sha256sums = SKIP
+
+pkgname = oacapture-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23917bfd1311
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=oacapture-git
+pkgver=bb7f8e6
+pkgrel=1
+pkgdesc="A planetary imaging application using Qt5"
+provides=("oacapture")
+conflicts=("oacapture")
+arch=('i686' 'x86_64')
+license=('GPLv3')
+depends=('qt5-base' 'qt5-tools' 'cfitsio' 'autoconf-archive' 'sdl' 'libdc1394')
+url="http://www.openastroproject.org/oacapture/"
+optdepends=('fxload: support for QHY5 cameras')
+
+source=("openastro-$pkgver::git+https://github.com/openastroproject/openastro#commit=${pkgver}")
+sha256sums=("SKIP")
+
+build() {
+ cd "openastro-${pkgver}"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "openastro-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # remove unwanted files
+ rm -rf ${pkgdir}/usr/include
+ rm -rf ${pkgdir}/usr/lib/*.a
+ rm -rf ${pkgdir}/usr/lib/pkgconfig
+ rm -rf ${pkgdir}/usr/share/doc/hidapi
+}