summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:32:28 +0200
committersl1pkn072015-06-08 20:32:28 +0200
commitbaafaf15b3ff549a9637e2814381b654082b909b (patch)
tree79912f28cac95bdeed704bdf813314ce6fe72e29
downloadaur-baafaf15b3ff549a9637e2814381b654082b909b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6786210e256d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-bilateral-git
+ pkgdesc = Plugin for Vapoursynth: bilateral (GIT version)
+ pkgver = r3.0.gdf53c02
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171306
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-bilateral
+ conflicts = vapoursynth-plugin-bilateral
+ source = bilateral::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Bilateral.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-bilateral-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc25475b71a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=bilateral
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r3.0.gdf53c02
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171306"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Bilateral.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ chmod +x "${_plug}/configure"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --gcc --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}