summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-20 10:50:47 -0500
committerCarlos Aznarán Laos2023-05-20 10:50:47 -0500
commitbac7a1141cda75e227e213a6527e864dd57ecc50 (patch)
tree516ceff39ca021f22cbdffa94fb2a02ff2b74716
parent2df0b242d83de8f527cb2a9310db4a3bd3e95615 (diff)
downloadaur-bac7a1141cda75e227e213a6527e864dd57ecc50.tar.gz
Change sources from GitHub to Pypi
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ad05ea645ea..09b691b28889 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,13 @@ pkgbase = python-pyviz_comms
url = https://github.com/pyviz/pyviz_comms
arch = any
license = custom:BSD-3-clause
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-param
depends = jupyterlab
- source = pyviz_comms-2.2.1.tar.gz::https://github.com/pyviz/pyviz_comms/archive/v2.2.1.tar.gz
- sha512sums = 7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e
+ source = https://pypi.org/packages/source/p/pyviz_comms/pyviz_comms-2.2.1.tar.gz
+ sha512sums = 5f66b3a0582a42163feaec078f6d8826126d985677bce21049a6613ea12c1f49cb54b2e3050cd16cadf055734b90280b43a4643329e9e89d76ca3bcb2794767c
pkgname = python-pyviz_comms
diff --git a/PKGBUILD b/PKGBUILD
index 8da36930f08b..50d623113481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,25 @@
# Contributor: jerry73204 <jerry73204 at google gmail>
_base=pyviz_comms
pkgname=python-${_base}
+pkgdesc="Bidirectional communication for the PyViz ecosystem"
pkgver=2.2.1
pkgrel=3
-pkgdesc='Bidirectional communication for the PyViz ecosystem'
arch=(any)
url="https://github.com/pyviz/${_base}"
license=('custom:BSD-3-clause')
-makedepends=(python-setuptools)
depends=(python-param jupyterlab)
-source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e')
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('5f66b3a0582a42163feaec078f6d8826126d985677bce21049a6613ea12c1f49cb54b2e3050cd16cadf055734b90280b43a4643329e9e89d76ca3bcb2794767c')
build() {
cd ${_base}-${pkgver}
- jlpm
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}