summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-11 13:03:37 -0500
committerVincent Grande2021-01-11 13:03:37 -0500
commitbae4912c3e6d190f938718fb87797c75ad0a0391 (patch)
treee46bd4f4bedbec17b8d98c7f90fc2c9f392269cf
downloadaur-bae4912c3e6d190f938718fb87797c75ad0a0391.tar.gz
fix
-rw-r--r--.SRCINFO23
-rw-r--r--COPYING48
-rw-r--r--PKGBUILD73
3 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f35fbf1e8e93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lib32-libdrm-minimal-git
+ pkgdesc = Userspace interface to kernel DRM services, git 32-bit version
+ pkgver = 2.4.100.r69.gfe06ee20
+ pkgrel = 1
+ url = http://dri.freedesktop.org/
+ arch = x86_64
+ license = custom
+ checkdepends = lib32-cairo
+ makedepends = meson
+ makedepends = git
+ makedepends = ninja
+ depends = libdrm-git
+ depends = lib32-libpciaccess
+ depends = lib32-gcc-libs
+ provides = lib32-libdrm
+ conflicts = lib32-libdrm
+ source = libdrm::git://anongit.freedesktop.org/mesa/drm#branch=master
+ source = COPYING
+ sha256sums = SKIP
+ sha256sums = 9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93
+
+pkgname = lib32-libdrm-minimal-git
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..6e74c337c3b9
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,48 @@
+ Copyright 2005 Adam Jackson.
+
+ Permission is hereby granted, free of charge, to any person obtaining
+ a copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation on the rights to use, copy, modify, merge,
+ publish, distribute, sub license, and/or sell copies of the Software,
+ and to permit persons to whom the Software is furnished to do so,
+ subject to the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial
+ portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NON-INFRINGEMENT. IN NO EVENT SHALL ADAM JACKSON BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+------------------------------------------------------------------------
+
+ Copyright 1999 Precision Insight, Inc., Cedar Park, Texas.
+ Copyright 2000 VA Linux Systems, Inc., Sunnyvale, California.
+ All Rights Reserved.
+
+ Permission is hereby granted, free of charge, to any person obtaining
+ a copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sublicense, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial
+ portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NONINFRINGEMENT. IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS
+ SUPPLIERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cc96346e478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Lone_Wolf <lonewolf@klaas-de-kat.nl>
+# Contributor: Eric Engestrom <eric@engestrom.ch>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=lib32-libdrm-minimal-git
+pkgver=2.4.100.r69.gfe06ee20
+pkgrel=1
+pkgdesc="Userspace interface to kernel DRM services, git 32-bit version"
+arch=(x86_64)
+license=('custom')
+depends=('libdrm-git' 'lib32-libpciaccess' 'lib32-gcc-libs')
+makedepends=('meson' 'git' 'ninja')
+checkdepends=('lib32-cairo')
+url="http://dri.freedesktop.org/"
+provides=('lib32-libdrm')
+conflicts=('lib32-libdrm')
+
+source=('libdrm::git://anongit.freedesktop.org/mesa/drm#branch=master'
+ COPYING)
+sha256sums=('SKIP'
+ '9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
+
+
+pkgver() {
+ cd libdrm
+ git describe --long --abbrev=8 | sed 's/^libdrm-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ if [ -d _build ]; then
+ rm -rf _build
+ fi
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG=/usr/bin/i686-pc-linux-gnu-pkg-config
+ meson setup libdrm _build \
+ --prefix /usr \
+ --libdir lib32 \
+ --buildtype plain \
+ --wrap-mode nofallback \
+ -D udev=false \
+ -D valgrind=false \
+ -D freedreno=false \
+ -D vc4=false \
+ -D vmwgfx=false \
+ -D radeon=false \
+ -D intel=false \
+ -D nouveau=false \
+ -D man-pages=false
+ meson configure _build
+ ninja $NINJAFLAGS -C _build
+}
+
+#check() {
+ # '-t 10' is needed for the 'threaded' test, which uses the default meson
+ # test timeout of 30 seconds. This is too short for many systems. It can be
+ # removed if upstream fixes the issue.
+# meson test -C _build -t 10
+#}
+
+package() {
+ DESTDIR="$pkgdir" ninja $NINJAFLAGS -C _build install
+
+ # remove files already provided by libdrm-git
+ rm -rf "$pkgdir"/usr/{include,share,bin}
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
+}