summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Wiedenmann2017-07-23 21:46:57 +0200
committerBjörn Wiedenmann2017-07-23 21:46:57 +0200
commitbb1349f4e2c2d885addd7a10567097e6b9ea1693 (patch)
tree255b9f5da3e31f1221833ab11a84d2b8246f3f68
parent141db55e8cc4aaabaa890edf469c823fc1082862 (diff)
downloadaur-bb1349f4e2c2d885addd7a10567097e6b9ea1693.tar.gz
Forced building against openssl-1.0
I am not happy with the solution though as I haven't found a clean way of forcing openssh to build against a specific openssl version. I tried pkg-config, but either it doesn't work or I am doing it wrong. Now I am using a hack, where I am using prepare() to symlink the openssl-1.0 files into the build directory and pass them to the configure script via the --with-ssl-dir option. If anyone has a cleaner way of doing this, please feel free to share it. Any help is greatly appreciated.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bab743b4d0ec..309df39a0510 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Jan 27 21:08:46 UTC 2017
+# Sun Jul 23 19:46:17 UTC 2017
pkgbase = pam_ssh_agent_auth-git
pkgdesc = PAM module which permits authentication for arbitrary services via ssh-agent. (Git version including experimental ECC support)
- pkgver = r19.0ff7282
- pkgrel = 1
+ pkgver = r22.f4b3932
+ pkgrel = 2
url = http://github.com/jbeverly/pam_ssh_agent_auth/
install = pam_ssh_agent_auth-git.install
arch = i686
arch = x86_64
license = custom:OpenSSL
+ depends = openssl-1.0
optdepends = openssh: standard ssh-agent
optdepends = gnupg: gpg ssh-agent
provides = pam_ssh_agent_auth
diff --git a/PKGBUILD b/PKGBUILD
index ac5118f1b99b..2f2f6d95cc61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -85,12 +85,13 @@
# please use the official pam_ssh_agent_auth code base instead.
pkgname=pam_ssh_agent_auth-git
-pkgver=r19.0ff7282
-pkgrel=1
+pkgver=r22.f4b3932
+pkgrel=2
pkgdesc="PAM module which permits authentication for arbitrary services via ssh-agent. (Git version including experimental ECC support)"
arch=('i686' 'x86_64')
url="http://github.com/jbeverly/pam_ssh_agent_auth/"
license=('custom:OpenSSL')
+depends=('openssl-1.0')
optdepends=('openssh: standard ssh-agent'
'gnupg: gpg ssh-agent')
provides=('pam_ssh_agent_auth')
@@ -109,6 +110,18 @@ pkgver() {
}
prepare() {
+ if ! [ -e openssl-1.0 ] ; then
+ mkdir openssl-1.0
+ fi
+
+ if ! [ -e openssl-1.0/include ] ; then
+ ln -s /usr/include/openssl-1.0 openssl-1.0/include
+ fi
+
+ if ! [ -e openssl-1.0/lib ] ; then
+ ln -s /usr/lib/openssl-1.0 openssl-1.0/lib
+ fi
+
cd "pam_ssh_agent_auth/"
git submodule init
git submodule update
@@ -116,7 +129,7 @@ prepare() {
build() {
cd "pam_ssh_agent_auth/"
- ./configure --prefix=/usr --with-mantype=man --libexecdir=/usr/lib/security
+ ./configure --prefix=/usr --with-mantype=man --libexecdir=/usr/lib/security --with-ssl-dir=../openssl-1.0
make
}