summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdavidwu2021-08-04 21:54:37 +0800
committerxdavidwu2021-08-04 21:54:37 +0800
commitbb1a005cc398887ebaf208c71143876251e5f5ae (patch)
treea27b83a53dd48eb901743cb698880f568badea52
parentd33c14fb9ef4da5158b1330c6d771fda9c30e8bf (diff)
downloadaur-bb1a005cc398887ebaf208c71143876251e5f5ae.tar.gz
16.0.2b7_openj9_0.27.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78732bbebece..80a23d9353f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = jdk-openj9-bin
pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk16
- pkgver = 16.0.1b9_openj9_0.26.0
+ pkgver = 16.0.2b7_openj9_0.27.0
pkgrel = 1
- url = https://adoptopenjdk.net/index.html?variant=openjdk16&jvmVariant=openj9
+ url = https://developer.ibm.com/languages/java/semeru-runtimes/downloads
arch = x86_64
license = custom
depends = java-environment-common
@@ -17,8 +17,7 @@ pkgbase = jdk-openj9-bin
conflicts = jdk16-openj9-bin
conflicts = jdk16-openj9
options = !strip
- source = https://github.com/AdoptOpenJDK/openjdk16-binaries/releases/download/jdk-16.0.1%2B9_openj9-0.26.0/OpenJDK16U-jdk_x64_linux_openj9_16.0.1_9_openj9-0.26.0.tar.gz
- sha256sums = 7395aaa479a7410bbe5bd5efc43d2669718c61ba146b06657315dbd467b98bf1
+ source = https://github.com/ibmruntimes/semeru16-binaries/releases/download/jdk-16.0.2%2B7_openj9-0.27.0/ibm-semeru-open-jdk_x64_linux_16.0.2_7_openj9-0.27.0.tar.gz
+ sha256sums = 1349eb9a1d9af491a1984d66a80126730357c4a5c4fcbe7112a2c832f6c0886e
pkgname = jdk-openj9-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 987836ef2e08..46e01be35927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@
pkgname=jdk-openj9-bin
_jdkver=16
_jdkminor=0
-_jdkpatch=1
+_jdkpatch=2
_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}
-_openj9ver=0.26.0
-_buildvershort=9
+_openj9ver=0.27.0
+_buildvershort=7
_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_jdkfullver}b${_buildver//-/_}
pkgrel=1
pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
-url="https://adoptopenjdk.net/index.html?variant=openjdk${_jdkver}&jvmVariant=openj9"
+url="https://developer.ibm.com/languages/java/semeru-runtimes/downloads"
license=('custom')
depends=('java-environment-common' 'ca-certificates-utils' 'nss')
provides=(
@@ -31,9 +31,9 @@ provides=(
)
conflicts=("jdk${_jdkver}-openj9-bin" "jdk${_jdkver}-openj9")
options=(!strip)
-source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_jdkfullver}_${_buildver}.tar.gz")
+source=("https://github.com/ibmruntimes/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-sha256sums=('7395aaa479a7410bbe5bd5efc43d2669718c61ba146b06657315dbd467b98bf1')
+sha256sums=('1349eb9a1d9af491a1984d66a80126730357c4a5c4fcbe7112a2c832f6c0886e')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9