summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-01-14 20:07:24 +0100
committerMatMoul2023-01-14 20:07:24 +0100
commitbb2e152db4fa47e2322ae8cf9715238763dab4af (patch)
tree9b7fcd6217d0b81721b03b43c114abe43f794322
parent11fe3fd4dd34fc0afa0fcc88c2f9b4526fed1bfd (diff)
downloadaur-bb2e152db4fa47e2322ae8cf9715238763dab4af.tar.gz
Version 0.1.1.r1.44c78be-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 967e510a43cf..191d203a7c49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = plasma-addons-customdesktopmenu-git
pkgdesc = Custom desktop menu for Plasma5
- pkgver = 0.1.1
+ pkgver = 0.1.1.r1.44c78be
pkgrel = 1
- url = https://github.com/MatMoul/plasma-containmentactions-customdesktopmenu
+ url = https://github.com/matmoul/plasma-containmentactions-customdesktopmenu
install = plasma-addons-customdesktopmenu-git.install
- arch = i686
- arch = x86_64
+ arch = any
license = GPL2
makedepends = git
- makedepends = make
- makedepends = cmake
makedepends = extra-cmake-modules
- depends = plasma-desktop
- options = !emptydirs
- source = https://github.com/MatMoul/plasma-containmentactions-customdesktopmenu/archive/v0.1.1.tar.gz
- sha256sums = 1605fec314098c42062da8592db4f54391ee96dc3b0169d9b577fbd26b6d2254
+ depends = plasma-workspace
+ source = git+https://github.com/matmoul/plasma-containmentactions-customdesktopmenu.git#commit=44c78befa925481ae96caa6cfd5476d13592b1d4
+ sha256sums = SKIP
pkgname = plasma-addons-customdesktopmenu-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9ab72d20e942..dbbf9f6a9e06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,31 @@
-# Maintainer: MatMoul <matmoul@gmail.com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=matmoul
+_githubrepo=plasma-containmentactions-customdesktopmenu
+_gitcommit=44c78befa925481ae96caa6cfd5476d13592b1d4
pkgname=plasma-addons-customdesktopmenu-git
-_appname=plasma-addons-customdesktopmenu
-_gitname=plasma-containmentactions-customdesktopmenu
-pkgver=0.1.1
+pkgver=0.1.1.r1.44c78be
pkgrel=1
-pkgdesc="Custom desktop menu for Plasma5"
-arch=('i686' 'x86_64')
-url="https://github.com/MatMoul/plasma-containmentactions-customdesktopmenu"
+pkgdesc='Custom desktop menu for Plasma5'
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
license=('GPL2')
-depends=('plasma-desktop')
-makedepends=('git' 'make' 'cmake' 'extra-cmake-modules')
-install=${pkgname}.install
-options=(!emptydirs)
-source=("https://github.com/MatMoul/${_gitname}/archive/v${pkgver}.tar.gz")
-sha256sums=('1605fec314098c42062da8592db4f54391ee96dc3b0169d9b577fbd26b6d2254')
+depends=('plasma-workspace')
+makedepends=('git' 'extra-cmake-modules')
+install="${pkgname}.install"
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}")
+sha256sums=('SKIP')
build() {
- cd ${_gitname}-${pkgver}/src
+ cd "${_githubrepo}"/src
mkdir build
cd build
- installlibdir=$(dirname $(find /usr -name plasma_containmentactions_contextmenu.so))
- cmake -DKDE_INSTALL_LIBDIR=$installlibdir ..
+ cmake ..
make
}
package() {
- cd ${_gitname}-${pkgver}/src/build
- installlibdir=$(dirname $(find /usr -name plasma_containmentactions_contextmenu.so))
- mkdir -p ${pkgdir}${installlibdir}
- mkdir -p ${pkgdir}/usr/local/share/kservices5
- cp plasma_containmentactions_customdesktopmenu.so ${pkgdir}${installlibdir}
- chmod -R 755 ${pkgdir}${installlibdir}
+ cd "${_githubrepo}"/src/build
+ install -D -m755 bin/plasma_containmentactions_customdesktopmenu.so ${pkgdir}/usr/lib/qt/plugins/plasma/containmentactions/plasma_containmentactions_customdesktopmenu.so
}