summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:27:55 -0600
committerJohn D Jones III2015-06-16 14:27:55 -0600
commitbb5eaa8a082de766fc67f954a89aa70732142d22 (patch)
tree5f258fdd99b766b109295046f952e5e521d35b87
downloadaur-bb5eaa8a082de766fc67f954a89aa70732142d22.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..944ba223ab31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-class-throwable
+ pkgdesc = A minimal lightweight exception class
+ pkgver = 0.11
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Class-Throwable
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/K/KM/KMX/Class-Throwable-0.11.tar.gz
+ md5sums = faf82871a6b471451cd65c54c6cac7e1
+ sha512sums = cfa053a9f20c2e619383711566df9de8fe22120545f3063f3661ff865e948a419aa9324c39c2b40e028564681d85a0421701f99d0ae285f483abf9e39d732d4a
+
+pkgname = perl-class-throwable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dacda0d446b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-class-throwable'
+pkgver='0.11'
+pkgrel='1'
+pkgdesc="A minimal lightweight exception class"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Class-Throwable'
+source=('http://search.cpan.org/CPAN/authors/id/K/KM/KMX/Class-Throwable-0.11.tar.gz')
+md5sums=('faf82871a6b471451cd65c54c6cac7e1')
+sha512sums=('cfa053a9f20c2e619383711566df9de8fe22120545f3063f3661ff865e948a419aa9324c39c2b40e028564681d85a0421701f99d0ae285f483abf9e39d732d4a')
+_distdir="Class-Throwable-0.11"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: