summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNigel Kukard2023-03-13 15:04:44 +0000
committerNigel Kukard2023-03-13 15:25:41 +0000
commitbb74c25a9194ed9c05a33307cc7ca6f37edae4a9 (patch)
treed074e9998597b9d6b9f38d0f1735535710f71c71
parentf07ad2d5d487b5c82d206dc1a7d8b61cc5408420 (diff)
downloadaur-bb74c25a9194ed9c05a33307cc7ca6f37edae4a9.tar.gz
fix: added patch to fix compiling on systems with libupnp installed
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD20
-rw-r--r--fix-upnp.patch14
4 files changed, 42 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f7f13d027eb..b98d9c652740 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asterisk
pkgdesc = A complete PBX solution
pkgver = 20.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.asterisk.org
arch = x86_64
arch = i686
@@ -142,9 +142,11 @@ pkgbase = asterisk
source = asterisk.sysusers
source = asterisk.logrotated
source = asterisk.tmpfiles
+ source = fix-upnp.patch
sha256sums = eca0f7ee7e49a72bdb0c26512db45c9683ca40c8fdf63466a04705ffaba04b85
sha256sums = 38a53911647fb2308482179cba605ebf12345df37eed23eb4ea67bf0bf041486
sha256sums = b97dc10a262621c95e4b75e024834712efd58561267b59b9171c959ecd9f7164
sha256sums = 1b6b489d4f71015bfc56ce739d92df7e9abdb349aed6f5a47dd9c18d84546c1b
+ sha256sums = 55798baa02698de3d81c4b6e11097b3dee73b20e9dfa1e08091a7037830ad6d8
pkgname = asterisk
diff --git a/.gitignore b/.gitignore
index 4f36969b662f..7078992e9667 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,9 @@
*
-!./.SRCINFO
-!./.gitignore
-!./PKGBUILD
-!./asterisk.install
-!./asterisk.logrotated
-!./asterisk.sysusers
-!./asterisk.tmpfiles
+!/.SRCINFO
+!/.gitignore
+!/PKGBUILD
+!/asterisk.install
+!/asterisk.logrotated
+!/asterisk.sysusers
+!/asterisk.tmpfiles
+!/fix-upnp.patch
diff --git a/PKGBUILD b/PKGBUILD
index b3b53444be7b..b20850d8e491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=asterisk
pkgver=20.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A complete PBX solution'
arch=(x86_64 i686 aarch64 armv7h)
url=https://www.asterisk.org
@@ -148,11 +148,25 @@ _archive="$pkgname-$pkgver"
source=("https://downloads.asterisk.org/pub/telephony/$pkgname/releases/$_archive.tar.gz"
"$pkgname.sysusers"
"$pkgname.logrotated"
- "$pkgname.tmpfiles")
+ "$pkgname.tmpfiles"
+ "fix-upnp.patch")
sha256sums=('eca0f7ee7e49a72bdb0c26512db45c9683ca40c8fdf63466a04705ffaba04b85'
'38a53911647fb2308482179cba605ebf12345df37eed23eb4ea67bf0bf041486'
'b97dc10a262621c95e4b75e024834712efd58561267b59b9171c959ecd9f7164'
- '1b6b489d4f71015bfc56ce739d92df7e9abdb349aed6f5a47dd9c18d84546c1b')
+ '1b6b489d4f71015bfc56ce739d92df7e9abdb349aed6f5a47dd9c18d84546c1b'
+ '55798baa02698de3d81c4b6e11097b3dee73b20e9dfa1e08091a7037830ad6d8')
+
+prepare() {
+ cd "$_archive"
+
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ echo "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+}
build() {
cd "$_archive"
diff --git a/fix-upnp.patch b/fix-upnp.patch
new file mode 100644
index 000000000000..f0eabb6ebe37
--- /dev/null
+++ b/fix-upnp.patch
@@ -0,0 +1,14 @@
+severach commented on 2023-03-12 22:02 (UTC)
+The update of third-party/{pjproject,versions.mak} from 2.12.1 to 2.13 is detecting libupnp on the system, usually from vlc, found on desktop systems, not found on Asterisk servers. This changes pjnath to -DPJNATH_HAS_UPNP=1 which causes -lupnp -lixml. Fix with this patch.
+
+diff --color -ru asterisk-20.2.0_vanilla/third-party/pjproject/Makefile.rules asterisk-20.2.0_libupnp-fix/third-party/pjproject/Makefile.rules
+--- asterisk-20.2.0_vanilla/third-party/pjproject/Makefile.rules 2023-03-09 17:17:03.000000000 +0000
++++ asterisk-20.2.0_libupnp-fix/third-party/pjproject/Makefile.rules 2023-03-13 14:49:56.566284230 +0000
+@@ -15,6 +15,7 @@
+ # Even though we're not installing pjproject, we're setting prefix to /opt/pjproject to be safe
+
+ PJPROJECT_CONFIG_OPTS = $(PJPROJECT_CONFIGURE_OPTS) --prefix=/opt/pjproject \
++ --disable-upnp \
+ --disable-speex-codec \
+ --disable-speex-aec \
+ --disable-bcg729 \