summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-05-07 14:56:21 -0700
committerJesus Alvarez2018-05-07 14:56:21 -0700
commitbb7ac63c90bdde7940677584715756251a6cedfb (patch)
treeba86c26cb046ef6b066b709e753765938f60f458
parent79d19cb16b9f8c6a27fa4dee34fb2ba418699237 (diff)
downloadaur-bb7ac63c90bdde7940677584715756251a6cedfb.tar.gz
Semi-automated update for 4.16.7.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 668fd41e7925..1d185650f4b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = spl-linux-git
- pkgver = 2018.05.02.r1073.84a80d5.4.16.6.1
+ pkgver = 2018.05.07.r1074.g1149b62.4.16.7.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-headers=4.16.6-1
+ makedepends = linux-headers=4.16.7-1
makedepends = git
- depends = spl-utils-common-git=2018.05.02.r1073.84a80d5
+ depends = spl-utils-common-git=2018.05.07.r1074.g1149b62
depends = kmod
- depends = linux=4.16.6-1
- source = git+https://github.com/zfsonlinux/spl.git#commit=84a80d5f2d14fdfd16d440eef2e3d6e756a1165c
+ depends = linux=4.16.7-1
+ source = git+https://github.com/zfsonlinux/spl.git#commit=1149b62d20b7ed9d8ae25d5da7a06213d79b7602
sha256sums = SKIP
pkgname = spl-linux-git
diff --git a/PKGBUILD b/PKGBUILD
index 1243391f264a..0f8fea3997ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
pkgbase="spl-linux-git"
pkgname=("spl-linux-git" "spl-linux-git-headers")
-pkgver=2018.05.02.r1073.84a80d5.4.16.6.1
+pkgver=2018.05.07.r1074.g1149b62.4.16.7.1
pkgrel=1
-makedepends=("linux-headers=4.16.6-1" "git")
+makedepends=("linux-headers=4.16.7-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/spl.git#commit=84a80d5f2d14fdfd16d440eef2e3d6e756a1165c")
+source=("git+https://github.com/zfsonlinux/spl.git#commit=1149b62d20b7ed9d8ae25d5da7a06213d79b7602")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git=2018.05.02.r1073.84a80d5" "kmod" "linux=4.16.6-1")
+depends=("spl-utils-common-git=2018.05.07.r1074.g1149b62" "kmod" "linux=4.16.7-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.16.6-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.16.6-1-ARCH/build \
+ --with-linux=/usr/lib/modules/4.16.7-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.16.7-1-ARCH/build \
--with-config=kernel
make
}
@@ -58,5 +58,5 @@ package_spl-linux-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.6-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.7-1-ARCH/Module.symvers
}
diff --git a/spl.install b/spl.install
index 1c396c4e46f6..bd23fb61b442 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.16.6-1-ARCH
+ depmod -a 4.16.7-1-ARCH
}