summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2019-07-22 18:55:04 +0200
committerGuilhem Saurel2019-07-22 18:55:04 +0200
commitbb81a404a3c998550e8a0e7dd059550e9b5362ac (patch)
treea5938b9e6d9c4ddf611298d76ea258b667ccb5b7
parentf95690c4b4a573fc29fddadb78a045c5d2d24717 (diff)
downloadaur-bb81a404a3c998550e8a0e7dd059550e9b5362ac.tar.gz
use MPI and build Python bindings
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e40e4762fb08..7b73f260816f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = med
- pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5
+ pkgdesc = Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5
pkgver = 4.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.salome-platform.org/downloads
arch = x86_64
license = LGPL
makedepends = gcc-fortran
- makedepends = python
makedepends = swig
makedepends = openmpi
makedepends = cmake
- depends = hdf5
+ depends = hdf5-openmpi
depends = tk
+ depends = python
source = http://files.salome-platform.org/Salome/other/med-4.0.0.tar.gz
sha256sums = a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004
diff --git a/PKGBUILD b/PKGBUILD
index 686e28a4ffed..6fc5a7159a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
pkgname=('med' 'med-docs')
pkgver=4.0.0
-pkgrel=3
-pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - MED is code-aster exchange module linked to hdf5"
+pkgrel=4
+pkgdesc="Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5"
url="https://www.salome-platform.org/downloads"
license=('LGPL')
-depends=('hdf5' 'tk')
-makedepends=('gcc-fortran' 'python' 'swig' 'openmpi' 'cmake')
+depends=('hdf5-openmpi' 'tk' 'python')
+makedepends=('gcc-fortran' 'swig' 'openmpi' 'cmake')
optdepends=()
arch=('x86_64')
source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz")
@@ -13,10 +13,17 @@ sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004')
build() {
cd ${pkgname}-${pkgver}
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMEDFILE_USE_MPI=ON -DMEDFILE_BUILD_PYTHON=ON .
make
}
+# I got 37 tests failed out of 91…
+#check() {
+ #cd "$pkgname-$pkgver"
+ #make test
+#}
+
package_med() {
cd ${pkgbase}-${pkgver}
make DESTDIR=${pkgdir} install