summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2023-10-20 00:07:00 -0700
committerTyler Veness2023-10-20 00:07:00 -0700
commitbba89ecb1b4ee44cfa2c28ee44f38f0c2783a8c8 (patch)
treefd0e1baedc19df6196a0e260c8871d6b0bc194eb
parent24d13b64f316f4726f214953689b6b213717a141 (diff)
downloadaur-bba89ecb1b4ee44cfa2c28ee44f38f0c2783a8c8.tar.gz
upgpkg: wpimath 2024.1.1-beta-1
-rw-r--r--.SRCINFO9
-rw-r--r--Add-missing-include.patch13
-rw-r--r--PKGBUILD18
3 files changed, 11 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 065cc9967b56..619e2aba3298 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wpimath
pkgdesc = WPILib's mathematics and controls library
- pkgver = 2023.4.3
- pkgrel = 3
+ pkgver = 2024.1.1b1
+ pkgrel = 1
url = https://github.com/wpilibsuite/allwpilib
arch = x86_64
license = BSD
@@ -9,13 +9,12 @@ pkgbase = wpimath
makedepends = cmake
depends = fmt
depends = eigen
+ depends = protobuf
options = !strip
options = staticlibs
- source = git+https://github.com/wpilibsuite/allwpilib#tag=v2023.4.3
+ source = git+https://github.com/wpilibsuite/allwpilib#tag=v2024.1.1-beta-1
source = Don_t-treat-warnings-as-errors.patch
- source = Add-missing-include.patch
md5sums = SKIP
md5sums = 06355c12d930efa26edbbe11f633831a
- md5sums = e2b9acf67122eca03efd62866a54ba59
pkgname = wpimath
diff --git a/Add-missing-include.patch b/Add-missing-include.patch
deleted file mode 100644
index f08bb4e941f8..000000000000
--- a/Add-missing-include.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/wpiutil/src/main/native/include/wpi/Base64.h b/wpiutil/src/main/native/include/wpi/Base64.h
-index c410bd0c26..858ff73fff 100644
---- a/wpiutil/src/main/native/include/wpi/Base64.h
-+++ b/wpiutil/src/main/native/include/wpi/Base64.h
-@@ -5,6 +5,8 @@
- #ifndef WPIUTIL_WPI_BASE64_H_
- #define WPIUTIL_WPI_BASE64_H_
-
-+#include <stdint.h>
-+
- #include <cstddef>
- #include <span>
- #include <string>
diff --git a/PKGBUILD b/PKGBUILD
index 035463978a71..8bcb1e93d813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
# Maintainer: Tyler Veness <calcmogul at gmail dot com>
pkgname=wpimath
-pkgver=2023.4.3
-pkgrel=3
+pkgver=2024.1.1b1
+pkgrel=1
pkgdesc="WPILib's mathematics and controls library"
arch=('x86_64')
url='https://github.com/wpilibsuite/allwpilib'
-depends=('fmt' 'eigen')
+depends=('fmt' 'eigen' 'protobuf')
makedepends=('cmake')
license=('BSD' 'MIT')
options=('!strip' 'staticlibs')
-source=('git+https://github.com/wpilibsuite/allwpilib#tag=v2023.4.3'
- 'Don_t-treat-warnings-as-errors.patch'
- 'Add-missing-include.patch')
+source=('git+https://github.com/wpilibsuite/allwpilib#tag=v2024.1.1-beta-1'
+ 'Don_t-treat-warnings-as-errors.patch')
md5sums=('SKIP'
- '06355c12d930efa26edbbe11f633831a'
- 'e2b9acf67122eca03efd62866a54ba59')
+ '06355c12d930efa26edbbe11f633831a')
prepare() {
cd allwpilib
patch -p1 < "$srcdir"/Don_t-treat-warnings-as-errors.patch
- patch -p1 < "$srcdir"/Add-missing-include.patch
}
build() {
@@ -41,8 +38,7 @@ build() {
}
check() {
- # wpiutil test failure: JsonComparisonValuesTest.Less
- ctest --test-dir build -E wpiutil --output-on-failure
+ ctest --test-dir build --output-on-failure
}
package() {