summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRihards Skuja2021-03-20 16:20:39 +0200
committerRihards Skuja2021-03-20 17:05:44 +0200
commitbbd21bea4ad77c66c539e8e7993646896e61ad8c (patch)
treef8df22c7043da4caebb7e580bb67f9ecf46380c7
parente1fce04f24d90117f30d3cdf9a20f4c3850c333d (diff)
downloadaur-bbd21bea4ad77c66c539e8e7993646896e61ad8c.tar.gz
Clean up PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 809f1a3b7219..5da6d25da812 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = kdeconnect-git
optdepends = python-nautilus: Nautilus integration
provides = kdeconnect
conflicts = kdeconnect
- source = git+https://invent.kde.org/kde/kdeconnect-kde.git
+ source = git+https://invent.kde.org/network/kdeconnect-kde.git
sha256sums = SKIP
pkgname = kdeconnect-git
diff --git a/PKGBUILD b/PKGBUILD
index cc7060e968f2..a617d6689097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,29 +18,24 @@ makedepends=(git extra-cmake-modules kdoctools qt5-declarative)
optdepends=('sshfs: remote filesystem browser'
'kde-cli-tools: configuration UI'
'python-nautilus: Nautilus integration')
-provides=($_pkgname)
conflicts=($_pkgname)
-source=("git+https://invent.kde.org/kde/$_remotename.git")
+provides=($_pkgname)
+source=("git+https://invent.kde.org/network/$_remotename.git")
sha256sums=('SKIP')
pkgver() {
- cd $_remotename
- printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
-prepare() {
- mkdir -p build
+ cd $_remotename
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {
- cd build
- cmake ../$_remotename \
- -DCMAKE_INSTALL_LIBEXECDIR=lib \
- -DBUILD_TESTING=OFF
- make
+ cmake -B build -S $_remotename \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}