summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-12-07 19:14:31 +0100
committersL1pKn072020-12-07 19:14:31 +0100
commitbbdecf8d3fce006dca9d13b2046e161ffe85aee7 (patch)
tree513c2112bb1d21d3ceb0d4042073fc514e4e4af1
parent2b777c8d829dfe63b15282f1af0d4ffa47b59e18 (diff)
downloadaur-bbdecf8d3fce006dca9d13b2046e161ffe85aee7.tar.gz
bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--esee24
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63b71f8f45fd..47bdf9fb1790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 20:00:55 UTC 2019
pkgbase = vapoursynth-plugin-vcmod
pkgdesc = Plugin for Vapoursynth: vcmod
- pkgver = 20171017
+ pkgver = 20200823
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=171412
arch = x86_64
license = GPL
depends = vapoursynth
- source = vcmod-20171017.7z::http://www.avisynth.nl/users/vcmohan/vcmod/vcmod_src.7z
- sha256sums = 40e621336e9995b47bbabfedcf79a5820a724acb57d86b8c83cd603ec0b595ca
+ source = vcmod-20200823.7z::http://www.avisynth.nl/users/vcmohan/vcmod/vcmod_src.7z
+ source = esee
+ sha256sums = c796d18aacc52cbd06b4df29680ca35f82441021d37b0c938e409e2d840f7d16
+ sha256sums = f56a5f44b92f431b5d8b4095e0d6a09bd62df2e4ea52e071770e1563df4e1b21
pkgname = vapoursynth-plugin-vcmod
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..fce6edeefba2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!esee
diff --git a/esee b/esee
new file mode 100644
index 000000000000..c63bbca37b66
--- /dev/null
+++ b/esee
@@ -0,0 +1,24 @@
+diff --git a/modNeural.cpp.esee b/modNeural.cpp
+index d4135b6..ba73036 100644
+--- a/modNeural.cpp.esee
++++ b/modNeural.cpp
+@@ -8,6 +8,19 @@ Author V.C.Mohan
+ Aug 26, 2017, Aug 20, 2020
+ ********************************************************************************/
+
++#if defined(__unix__)
++static inline void linux_strcpy_s(char *dest, size_t destsz, const char *src){
++ strcpy(dest, src);
++}
++
++static inline void linux_strcat_s(char *dest, size_t destsz, const char *src){
++ strcat(dest, src);
++}
++
++#define strcpy_s linux_strcpy_s
++#define strcat_s linux_strcat_s
++#endif
++
+
+ typedef struct {
+