summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2020-05-28 16:39:08 +0200
committerMatthias Lisin2020-05-28 16:39:08 +0200
commitbc4b239779306eb3173ca3ed633200c11504df6f (patch)
treecad2a5e63534be05fe814d4e6cb7e7cedd467c28
downloadaur-bc4b239779306eb3173ca3ed633200c11504df6f.tar.gz
newpkg: helm-edit 0.4.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD39
-rw-r--r--helm-edit.install4
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..448731980882
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = helm-edit
+ pkgdesc = Helm plugin to edit releases
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/mstrzele/helm-edit
+ install = helm-edit.install
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = bash
+ depends = helm>=3.0.0
+ source = helm-edit-0.4.0.tar.gz::https://github.com/mstrzele/helm-edit/archive/v0.4.0.tar.gz
+ sha256sums = 97a0bb6573f886738665de6c3ff355debf541378dfe01443bf456bc60778c6aa
+
+pkgname = helm-edit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f1ecb611e6e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.log
+/*.tar.gz
+/*.pkg.tar*
+/*.src.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbe19615aca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: ml <ml@visu.li>
+pkgname=helm-edit
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Helm plugin to edit releases'
+arch=('x86_64')
+url='https://github.com/mstrzele/helm-edit'
+license=('MIT')
+install=helm-edit.install
+depends=('bash' 'helm>=3.0.0')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('97a0bb6573f886738665de6c3ff355debf541378dfe01443bf456bc60778c6aa')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ #go mod download
+ go mod tidy # required for -mod=readonly due to missing checksums
+ sed -i '/^hooks:$/Q' plugin.yaml
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_ENABLED=1
+ export CGO_LDFLAGS="$LDFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
+ go build -o helm-edit
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 helm-edit -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}/bin"
+ install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
+ install -m755 plugin.complete -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/helm-edit.install b/helm-edit.install
new file mode 100644
index 000000000000..a34d3cf7d821
--- /dev/null
+++ b/helm-edit.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Run the following command to finish plugin installation:"
+ echo -e "\thelm plugin install /usr/lib/helm/plugins/edit"
+}