summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2023-03-19 14:25:29 +0100
committerJean-Marc Lenoir2023-03-19 14:25:29 +0100
commitbc5d14f958ba758c4a9113de337902e173304ece (patch)
treea63dc4df1940d9e8ea8aee3da788c9d598ce3ccd
parent671038e0f513ec8a9af2dfc92f88b6a03e09e6a5 (diff)
downloadaur-bc5d14f958ba758c4a9113de337902e173304ece.tar.gz
Fix a potential crash when loading vmnet module
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--vmnet.patch138
3 files changed, 142 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 158d8533549a..bbcccc981873 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation15
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.7
- pkgrel = 13
+ pkgrel = 14
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -87,6 +87,6 @@ pkgbase = vmware-workstation15
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
sha256sums = 5b7c4ada0218214fa04ccb1f6c8033571f3991a83c5a613692db7a71e48d62c7
- sha256sums = 73ab76a12dfe20159646ffa599f004b3d911152599866b6b2339bc38fe3ace78
+ sha256sums = 508d3bc4e130701a64b430a88e8ef9ea6f40e818744b14a84415945ec0eac1d7
pkgname = vmware-workstation15
diff --git a/PKGBUILD b/PKGBUILD
index de0fcc6ab21c..d1c65a2ce0bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation15
pkgver=15.5.7
_buildver=17171714
_pkgver=${pkgver}_${_buildver}
-pkgrel=13
+pkgrel=14
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -124,7 +124,7 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
'5b7c4ada0218214fa04ccb1f6c8033571f3991a83c5a613692db7a71e48d62c7'
- '73ab76a12dfe20159646ffa599f004b3d911152599866b6b2339bc38fe3ace78'
+ '508d3bc4e130701a64b430a88e8ef9ea6f40e818744b14a84415945ec0eac1d7'
)
options=(!strip emptydirs)
diff --git a/vmnet.patch b/vmnet.patch
index c0f133b34719..feb6f624f606 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -265,3 +265,141 @@
}
e = e->nextEvent;
}
+From 650fb3abeb82f2b7d3a14f9579a7529d153636b7 Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Fri, 7 Oct 2022 12:56:44 +0200
+Subject: [PATCH] vmnet: work around field-spanning write warning (#195)
+
+While VMware 17.0.1 did work around the field-spanning write warning in
+VNetEvent_Send() by wrapping struct VNet_EventHeader into a union, they
+neglected to handle the same problem in VNetUserListenerEventHandler() so
+that running 17.0.1 on kernel >= 6.1-rc1 still issues
+
+ memcpy: detected field-spanning write (size 28) of single field "&t->event"
+
+only this time it happens on VM start rather than on module load. Apply the
+same workaround as in 17.0.0 branch to avoid the warning.
+---
+ vmnet-only/vnet.h | 8 ++++++++
+ vmnet-only/vnetEvent.c | 2 +-
+ vmnet-only/vnetUserListener.c | 2 +-
+ 3 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/vmnet-only/vnet.h b/vmnet-only/vnet.h
+index d6691d5c..d5bb5572 100644
+--- a/vmnet-only/vnet.h
++++ b/vmnet-only/vnet.h
+@@ -274,6 +274,7 @@ typedef struct VNet_EventHeader {
+ uint32 eventId;
+ uint32 classSet;
+ uint32 type;
++ char payload[];
+ } VNet_EventHeader;
+ #pragma pack(pop)
+
+@@ -291,6 +292,13 @@ typedef struct VNet_LinkStateEvent {
+ } VNet_LinkStateEvent;
+ #pragma pack(pop)
+
++static inline void VNet_Event_copy(VNet_EventHeader *dst,
++ const VNet_EventHeader *src)
++{
++ *dst = *src;
++ memcpy(dst->payload, src->payload, src->size - sizeof(*src));
++}
++
+ /*
+ *----------------------------------------------------------------------------
+ */
+diff --git a/vmnet-only/vnetEvent.c b/vmnet-only/vnetEvent.c
+index f1579292..12036070 100644
+--- a/vmnet-only/vnetEvent.c
++++ b/vmnet-only/vnetEvent.c
+@@ -401,7 +401,7 @@ VNetEvent_Send(VNetEvent_Sender *s, // IN: a sender
+ p->nextEvent = s->firstEvent;
+ s->firstEvent = p;
+ }
+- memcpy(&p->event, e, e->size);
++ VNet_Event_copy(&p->event.header, e);
+
+ /* send event */
+ classSet = e->classSet;
+diff --git a/vmnet-only/vnetUserListener.c b/vmnet-only/vnetUserListener.c
+index 114f3907..e9f51755 100644
+--- a/vmnet-only/vnetUserListener.c
++++ b/vmnet-only/vnetUserListener.c
+@@ -226,7 +226,7 @@ VNetUserListenerEventHandler(void *context, // IN: the user listener
+ return;
+ }
+ t->nextEvent = NULL;
+- memcpy(&t->event, e, e->size);
++ VNet_Event_copy(&t->event, e);
+
+ /* append event to event list */
+ userListener = (VNetUserListener*)context;
+From 0ca979d4bd06144204d720bb82f0a1e29024f9fa Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Wed, 18 Jan 2023 00:19:52 +0100
+Subject: [PATCH] vmnet: use explicit module_init() and module_exit() (#187)
+
+While vmmon module already uses explicit module_init() and module_exit()
+for its init and cleanup function, vmnet relies on traditional magic names
+init_module() and cleanup_module(). Apparently this has an unfortunate side
+effect that the two functions are not identified as indirect call targets
+by objdump and they get "sealed" when the module is built against and
+loaded into an IBT enabled kernel.
+
+Starting with 6.3-rc1, objtool is going to warn about this issue,
+indicating that the legacy module initialization is deprecated and
+module_init() and module_exit() macros should be used instead so do that
+for vmnet as well.
+---
+ vmnet-only/driver.c | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/vmnet-only/driver.c b/vmnet-only/driver.c
+index 197a213..b22cbfb 100644
+--- a/vmnet-only/driver.c
++++ b/vmnet-only/driver.c
+@@ -279,7 +279,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
+ /*
+ *----------------------------------------------------------------------
+ *
+- * init_module --
++ * vmnet_init_module --
+ *
+ * linux module entry point. Called by /sbin/insmod command.
+ * Initializes module and Registers this driver for a
+@@ -296,7 +296,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
+ */
+
+ int
+-init_module(void)
++vmnet_init_module(void)
+ {
+ int retval;
+
+@@ -358,7 +358,7 @@ init_module(void)
+ /*
+ *----------------------------------------------------------------------
+ *
+- * cleanup_module --
++ * vmnet_cleanup_module --
+ *
+ * Called by /sbin/rmmod. Unregisters this driver for a
+ * vnet major #, and deinitializes the modules. The 64-bit
+@@ -375,7 +375,7 @@ init_module(void)
+ */
+
+ void
+-cleanup_module(void)
++vmnet_cleanup_module(void)
+ {
+ unregister_chrdev(VNET_MAJOR_NUMBER, "vmnet");
+ VNetProtoUnregister();
+@@ -1701,3 +1701,5 @@ MODULE_LICENSE("GPL v2");
+ * by default (i.e., neither mkinitrd nor modprobe will accept it).
+ */
+ MODULE_INFO(supported, "external");
++module_init(vmnet_init_module);
++module_exit(vmnet_cleanup_module);