summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcgyver2020-02-18 01:03:41 +0000
committermcgyver2020-02-18 01:03:41 +0000
commitbc74648ae5124378df655ff11f07f4e4204c9c7a (patch)
tree994a103e1d875a37014d72d98733b29eca2af627
downloadaur-bc74648ae5124378df655ff11f07f4e4204c9c7a.tar.gz
Initial PKGBUILD commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5c8b4fc6afe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-lazyarray
+ pkgdesc = a Python package that provides a lazily-evaluated numerical array class, larray, based on and compatible with NumPy arrays
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://pypi.org/project/lazyarray/#files
+ arch = any
+ license = BSD
+ makedepends = python
+ makedepends = python2
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/l/lazyarray/lazyarray-0.3.3.tar.gz
+ sha256sums = SKIP
+
+pkgname = python-lazyarray
+ depends = python
+
+pkgname = python2-lazyarray
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11248efe553
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: mcgyver <newsletter.sergio@gmail.com>
+
+pkgbase=python-lazyarray
+pkgname=('python-lazyarray' 'python2-lazyarray')
+_name=${pkgbase#python-}
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="a Python package that provides a lazily-evaluated numerical array class, larray, based on and compatible with NumPy arrays"
+arch=('any')
+url="https://pypi.org/project/lazyarray/#files"
+license=('BSD')
+makedepends=("python" "python2" 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package_python-lazyarray() {
+ depends+=('python')
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+}
+
+package_python2-lazyarray() {
+ depends+=('python2')
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}"
+}
+