summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-09-15 23:10:34 -0700
committerLlewelyn Trahaearn2016-09-15 23:10:34 -0700
commitbc74731112ba8ea5a854f5eb165cddec01398139 (patch)
treef506a9dbb1904fbae3e42372cb8329ca58ce8eb2
parenta6591e6788b9c65ec1dce202c6f433e345d7104f (diff)
downloadaur-bc74731112ba8ea5a854f5eb165cddec01398139.tar.gz
Add submodules to sources array.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bcc3bf9d99b..8b74e8fbf609 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Sep 5 04:14:18 UTC 2016
+# Fri Sep 16 06:09:59 UTC 2016
pkgbase = zynaddsubfx-git
pkgdesc = A powerful realtime, multi-timbral software synthesizer.
- pkgver = 2.5.4.r134.ge5a26ab
+ pkgver = 2.5.4.r138.g0776bad
pkgrel = 1
url = http://zynaddsubfx.sourceforge.net
arch = i686
@@ -27,8 +27,14 @@ pkgbase = zynaddsubfx-git
noextract = unsortedzynaddsubfxParameters_20140402.zip
options = !emptydirs
source = zynaddsubfx-git::git://git.code.sf.net/p/zynaddsubfx/code/
+ source = DPF::git+https://github.com/DISTRHO/DPF.git
+ source = instruments::git://git.code.sf.net/p/zynaddsubfx/instruments
+ source = rtosc::git+https://github.com/fundamental/rtosc.git
source = http://zynaddsubfx.sourceforge.net/doc/instruments/unsortedzynaddsubfxParameters_20140402.zip
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = 13e7ed9746d0ce7959afa067211175cd007fdeb77500756dd5b0a57e6230e425934a7fe267a5197b539c3305c497745beb2fef2f5e79e4c8662a9c57cf2345f0
pkgname = zynaddsubfx-git
diff --git a/PKGBUILD b/PKGBUILD
index 90ac33ac76a2..a070b6b4a9d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: speps <speps at aur dot archlinux dot org>
pkgname=zynaddsubfx-git
-pkgver=2.5.4.r134.ge5a26ab
+pkgver=2.5.4.r138.g0776bad
pkgrel=1
pkgdesc="A powerful realtime, multi-timbral software synthesizer."
arch=('i686' 'x86_64')
@@ -15,9 +15,15 @@ provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!emptydirs')
source=("${pkgname}::git://git.code.sf.net/p/zynaddsubfx/code/"
+ "DPF::git+https://github.com/DISTRHO/DPF.git"
+ "instruments::git://git.code.sf.net/p/zynaddsubfx/instruments"
+ "rtosc::git+https://github.com/fundamental/rtosc.git"
"http://zynaddsubfx.sourceforge.net/doc/instruments/unsortedzynaddsubfxParameters_20140402.zip")
-noextract=("${source[1]##*/}")
+noextract=("${source[4]##*/}")
sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'13e7ed9746d0ce7959afa067211175cd007fdeb77500756dd5b0a57e6230e425934a7fe267a5197b539c3305c497745beb2fef2f5e79e4c8662a9c57cf2345f0')
_branch=master
@@ -33,9 +39,12 @@ prepare() {
cd "${pkgname}"
[ -d build ] || mkdir build
git checkout ${_branch}
-
- # Pull rtosc and instruments
- git submodule update --init
+ git pull
+ git submodule init
+ git config submodule.DPF.url "${srcdir}/DPF"
+ git config submodule.instruments.url "${srcdir}/instruments"
+ git config submodule.rtosc.url "${srcdir}/rtosc"
+ git submodule update DPF instruments rtosc
# Prevent use of /usr/lib64
sed -i 's:lib64:lib:' src/CMakeLists.txt
@@ -76,7 +85,7 @@ package() {
# Additional parameters
install -d "${pkgdir}/usr/share/${pkgname%-*}/parameters"
bsdtar --strip-components 1 --uid 0 --gid 0 -zxf \
- ${srcdir}/${source[1]##*/} -C \
+ ${srcdir}/${source[4]##*/} -C \
"${pkgdir}/usr/share/${pkgname%-*}/parameters"
# Desktop file sans predefied I/O