summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitbc960343821ec98a6c9b734d00c1059f01e83eac (patch)
treea8f07082cf1b97de51c4640d460d96774b854ef0
downloadaur-bc960343821ec98a6c9b734d00c1059f01e83eac.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
3 files changed, 52 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..32991fa9d106
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = dslib
+ pkgdesc = Free Python library for accessing Datove schranky
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://labs.nic.cz/page/740/dsgui/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2-pyopenssl
+ source = http://www.nic.cz/public_media/datove_schranky/releases/src/dslib-3.1.tar.gz
+
+pkgname = dslib
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da03b8b3ea8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dslib
+ pkgdesc = Free Python library for accessing Datove schranky
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://labs.nic.cz/page/740/dsgui/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2-pyopenssl
+ source = http://www.nic.cz/public_media/datove_schranky/releases/src/dslib-3.1.tar.gz
+ sha256sums = 7f5542f57c5b54f3190b7497b1da4acb04061639e9db3a7e99db33b3c3359b16
+
+pkgname = dslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea2227601503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=dslib
+pkgver=3.1
+pkgrel=1
+pkgdesc="Free Python library for accessing Datove schranky"
+arch=('any')
+url="http://labs.nic.cz/page/740/dsgui/"
+license=('LGPL')
+depends=('python2-pyopenssl')
+makedepends=('python2-setuptools')
+source=(http://www.nic.cz/public_media/datove_schranky/releases/src/$pkgname-$pkgver.tar.gz)
+sha256sums=('7f5542f57c5b54f3190b7497b1da4acb04061639e9db3a7e99db33b3c3359b16')
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+#Python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py install --root="${pkgdir}"
+}