summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRouzbeh2015-11-30 20:45:51 +0000
committerRouzbeh2015-11-30 20:45:51 +0000
commitbcbb137c235eb1f545901cb26bf137ebec4c4560 (patch)
tree368dd0a2935448b4f996be1a7b804cd191b1cb68
parent87408be2766572e70702fc79cc58da032f852bb8 (diff)
downloadaur-bcbb137c235eb1f545901cb26bf137ebec4c4560.tar.gz
Update to v7.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--patch.diff64
3 files changed, 8 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1a654db5df0..7667c40578d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neuron
pkgdesc = Empirically-based simulations of neurons and networks of neurons
- pkgver = 7.3
- pkgrel = 8
+ pkgver = 7.4
+ pkgrel = 1
url = http://www.neuron.yale.edu
arch = i686
arch = x86_64
@@ -13,10 +13,8 @@ pkgbase = neuron
optdepends = python-scipy
optdepends = mpich2
options = libtool
- source = http://www.neuron.yale.edu/ftp/neuron/versions/v7.3/nrn-7.3.tar.gz
- source = patch.diff
- md5sums = 993e539cb8bf102ca52e9fefd644ab61
- md5sums = ba01405ea8ff911a3802459ac2c27b01
+ source = http://www.neuron.yale.edu/ftp/neuron/versions/v7.4/nrn-7.4.tar.gz
+ md5sums = 2c0bbee8a9e55d60fa26336f4ab7acbf
pkgname = neuron
diff --git a/PKGBUILD b/PKGBUILD
index 3dd3054b385a..2a5a77a7c596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: David Campbell <davekong@archlinux.us>
pkgname=neuron
-pkgver=7.3
-pkgrel=8
+pkgver=7.4
+pkgrel=1
pkgdesc="Empirically-based simulations of neurons and networks of neurons"
arch=('i686' 'x86_64')
url="http://www.neuron.yale.edu"
license=('GPL')
depends=('interviews' 'openmpi' 'python')
optdepends=('python-numpy' 'python-scipy' 'mpich2')
-source=("http://www.neuron.yale.edu/ftp/neuron/versions/v$pkgver/nrn-$pkgver.tar.gz" "patch.diff")
+source=("http://www.neuron.yale.edu/ftp/neuron/versions/v$pkgver/nrn-$pkgver.tar.gz")
options=('libtool')
-md5sums=('993e539cb8bf102ca52e9fefd644ab61' 'ba01405ea8ff911a3802459ac2c27b01')
+md5sums=('2c0bbee8a9e55d60fa26336f4ab7acbf')
build() {
cd "$srcdir/nrn-$pkgver"
@@ -21,10 +21,6 @@ build() {
sed -i "s_ac\_pysetup='--home=\$(prefix)'_ac\_pysetup='--home=$pkgdir/usr'_g" "$srcdir/nrn-$pkgver/configure"
sed -i 's_exec\_prefix="${prefix}/${host\_cpu}"_exec\_prefix="${prefix}"_g' "$srcdir/nrn-$pkgver/configure"
- # Python 3 complains about a prototype (see http://www.neuron.yale.edu/phpbb/viewtopic.php?f=2&t=3060).
- # This part patches some code according to http://www.neuron.yale.edu/hg/neuron/nrn/rev/dce1de58303d.
- patch -p1 < $srcdir/patch.diff
-
./configure --prefix=/usr --libdir=/usr/lib --bindir=/usr/bin --with-paranrn --with-nrnpython=`which python`
make
}
diff --git a/patch.diff b/patch.diff
deleted file mode 100644
index f9daec39aed7..000000000000
--- a/patch.diff
+++ /dev/null
@@ -1,64 +0,0 @@
-
-# HG changeset patch
-# User Michael Hines <michael.hines@yale.edu>
-# Date 1398115465 14400
-# Node ID dce1de58303d5f733ca4fa6701083455ce0d10c8
-# Parent 840b0bd992336e3bc047c829a18a5e609f71de56
-Python 3.4 complained about a prototype.
-
-diff -r 840b0bd99233 -r dce1de58303d src/nrnpython/nrnpython.cpp
---- a/src/nrnpython/nrnpython.cpp Mon Apr 21 13:33:19 2014 -0400
-+++ b/src/nrnpython/nrnpython.cpp Mon Apr 21 17:24:25 2014 -0400
-@@ -17,11 +17,11 @@
- extern int nrnpy_nositeflag;
- extern char* hoc_ctp;
- extern FILE* hoc_fin;
--extern char* hoc_promptstr;
-+extern const char* hoc_promptstr;
- extern char* neuronhome_forward();
- //extern char*(*PyOS_ReadlineFunctionPointer)(FILE*, FILE*, char*);
- #if ((PY_MAJOR_VERSION >= 3) || (PY_MAJOR_VERSION == 2 && PY_MINOR_VERSION > 2))
--static char* nrnpython_getline(FILE*, FILE*, char*);
-+static char* nrnpython_getline(FILE*, FILE*, const char*);
- #else
- static char* nrnpython_getline(char*);
- #endif
-@@ -207,7 +207,7 @@
- }
-
- #if ((PY_MAJOR_VERSION >= 3) || (PY_MAJOR_VERSION == 2 && PY_MINOR_VERSION > 2))
--static char* nrnpython_getline(FILE*, FILE*, char* prompt) {
-+static char* nrnpython_getline(FILE*, FILE*, const char* prompt) {
- #else
- static char* nrnpython_getline(char* prompt) {
- #endif
-diff -r 840b0bd99233 -r dce1de58303d src/oc/hoc.c
---- a/src/oc/hoc.c Mon Apr 21 13:33:19 2014 -0400
-+++ b/src/oc/hoc.c Mon Apr 21 17:24:25 2014 -0400
-@@ -122,6 +122,7 @@
- #endif
-
- #if READLINE
-+extern char* readline(const char* prompt);
- extern void rl_deprep_terminal(void);
- extern void add_history(const char*);
- #endif
-@@ -146,7 +147,7 @@
- #define CBUFSIZE 512
- HocStr* hoc_tmpbuf;
- HocStr* hoc_cbufstr;
--char* hoc_promptstr;
-+const char* hoc_promptstr;
- static CHAR *cbuf;
- CHAR *ctp;
- int hoc_ictp;
-@@ -1692,7 +1693,7 @@
- }
- }else{
- #if READLINE
-- if (nrn_fw_eq(fin, stdin) && nrn_istty_) { char *line, *readline(); int n;
-+ if (nrn_fw_eq(fin, stdin) && nrn_istty_) { char *line; int n;
- #if INTERVIEWS
- #ifdef MINGW
- IFGUI
-