summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:03:03 +0100
committerDaniel Peukert2024-01-28 00:03:03 +0100
commitbd32a677bf9843cccff8b8d9e3a128e00cbf2f11 (patch)
treebbccc357b755c9cc52378250bf6c05d573dca8cb
parent373d940ba8a5dfeab560b55ece3e47c6939ac950 (diff)
downloadaur-bd32a677bf9843cccff8b8d9e3a128e00cbf2f11.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD2
2 files changed, 15 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 5e12af68f033..215e231aa272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,6 +29,6 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/MIT"
install -Dm644 "$_pkgname.1" "$pkgdir/usr/share/man/man1/$_pkgname.1"
}