summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-21 23:05:03 +0100
committerDaniel Peukert2024-01-21 23:05:03 +0100
commitbd36cc96e3bcbcaeddbaadd21090a5bc529d708a (patch)
tree485e69e47488a0f434ecc70057323ab144c53d4f
parent0879dd9e1f83d8755f7092411c62d51eff24a05b (diff)
downloadaur-bd36cc96e3bcbcaeddbaadd21090a5bc529d708a.tar.gz
Update mongodb-compass-beta to 1.42.0-beta.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0631011929d0..d42775b60284 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = mongodb-compass-readonly-git
pkgdesc = The official GUI for MongoDB - Readonly Edition - git version
- pkgver = r16664.g4a719aa32
+ pkgver = r16716.gfd2aab99c
pkgrel = 1
epoch = 1
url = https://www.mongodb.com/products/compass
arch = x86_64
arch = armv7h
arch = aarch64
- license = custom:SSPL
+ license = SSPL-1.0
makedepends = git
makedepends = npm>=8.19.4
makedepends = python
makedepends = unzip
- depends = electron25
+ depends = electron28
depends = krb5
depends = libsecret
depends = lsb-release
diff --git a/PKGBUILD b/PKGBUILD
index deb12d3f27c1..e67d36831d0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _target='compass-readonly'
_edition=' Readonly'
_pkgname="mongodb-$_target"
pkgname="$_pkgname-git"
-pkgver='r16664.g4a719aa32'
+pkgver='r16716.gfd2aab99c'
pkgrel='1'
epoch='1'
pkgdesc='The official GUI for MongoDB - Readonly Edition - git version'
@@ -11,8 +11,8 @@ pkgdesc='The official GUI for MongoDB - Readonly Edition - git version'
# If you're running on armv7h, you have to add it to the arch and source arrays of the electron25-bin AUR dependency
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.mongodb.com/products/compass'
-license=('custom:SSPL')
-_electronpkg='electron25'
+license=('SSPL-1.0')
+_electronpkg='electron28'
depends=("$_electronpkg" 'krb5' 'libsecret' 'lsb-release' 'nodejs>=16.15.1')
makedepends=('git' 'npm>=8.19.4' 'python' 'unzip')
optdepends=('org.freedesktop.secrets')
@@ -37,13 +37,20 @@ prepare() {
# Disable husky command
sed -i '/husky install/d' 'package.json'
+ # Working around https://gitlab.archlinux.org/archlinux/packaging/packages/electron28/-/issues/1
+ _installedelectronver="$(cat "/usr/lib/$_electronpkg/version")"
+
+ if [ "$_installedelectronver" = '28.1.5' ]; then
+ _installedelectronver='28.1.4'
+ fi
+
# Set system Electron version for ABI compatibility
- sed -E -i 's|("electron": ").*"|\1'"$(cat "/usr/lib/$_electronpkg/version")"'"|' {'configs','packages'}'/'*'/package.json'
+ sed -E -i 's|("electron": ").*"|\1'"$_installedelectronver"'"|' {'configs','packages'}'/'*'/package.json'
# Force the newest version of electron-to-chromium
sed -E -i 's|(.*)("electron": ")|\1"electron-to-chromium": "'"$(npm view 'electron-to-chromium@latest' version)"'",\n\1\2|' 'packages/compass/package.json'
- # Use a fork of os-dns-native (as there are issues with the path not being in the main node_modules directory, a local copy is not used)
+ # Use a new version of os-dns-native
sed -E -i "s|(.*)\"os-dns-native\": \".*\",|\1\"os-dns-native\": \"1\.2\.1\",|" 'packages/compass/package.json'
patch --forward -p1 < "$srcdir/hadron-build-os-dns-native.diff"
@@ -116,7 +123,6 @@ EOF
install -Dm644 "$srcdir/$_sourcedirectory/packages/compass/app-icons/linux/mongodb-compass.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
install -dm755 "$pkgdir/usr/share/licenses/$pkgname/"
- for _license in 'LICENSE' 'LICENSES.chromium.html'; do
- install -Dm644 "$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
- done
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/SSPL-1.0"
+ install -Dm644 'LICENSES.chromium.html' "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
}