summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorehsan gn2021-06-13 19:34:26 +0430
committerehsan gn2021-06-13 19:34:26 +0430
commitbd42465a6234ab0fe95ec9e371f377dcba512d42 (patch)
tree7c8dffb8907de2739fa462784ac38befb782381c
parenteca6d328b2db61c19c3c4595e699df8b0ec7e22c (diff)
downloadaur-bd42465a6234ab0fe95ec9e371f377dcba512d42.tar.gz
fix conflict with pacman-contrib, minor improvements
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--config (renamed from paclist.conf)0
-rw-r--r--paclist.hook1
-rwxr-xr-xpaclist.sh2
5 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99deb33d683a..280adb91995a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,10 +7,10 @@ pkgbase = paclist
provides = paclist
conflicts = paclist
source = paclist.sh
- source = paclist.conf
source = paclist.hook
- sha256sums = 797cf54f8bf1f2bd471b00dcfbe568c60d1c637783655ffc75b93034b64502a9
+ source = config
+ sha256sums = b2423b71c85c00c5ffccf78dd8ed859edbbacac9f3765fa2ea6cb9662e9736a8
+ sha256sums = 69e6e0389bb29cd491306e8f2c611f59b0e6122007567e8b9f41d7bbda4aebcb
sha256sums = 5460135c15426c7845a8cb84a424c1501b12a9f6c4451600d03e1bce266acf45
- sha256sums = 59d60913b1c473eb4b9d13b833e76d8d4867f200c6a5cb42de8721e06aa44cbb
pkgname = paclist
diff --git a/PKGBUILD b/PKGBUILD
index 5d0c03e761b6..679f6a7f4dcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Ehsan Ghorbannezad <ehsangn@protonmail.ch>
pkgname=paclist
-pkgver=r1
+pkgver=r2
pkgrel=1
pkgdesc='pacman hook to make lists of installed packages.'
arch=(any)
license=(GPL)
-source=($pkgname.sh $pkgname.conf $pkgname.hook)
+source=($pkgname.sh $pkgname.hook config)
provides=($pkgname)
conflicts=($pkgname)
sha256sums=(
- 797cf54f8bf1f2bd471b00dcfbe568c60d1c637783655ffc75b93034b64502a9
+ b2423b71c85c00c5ffccf78dd8ed859edbbacac9f3765fa2ea6cb9662e9736a8
+ 69e6e0389bb29cd491306e8f2c611f59b0e6122007567e8b9f41d7bbda4aebcb
5460135c15426c7845a8cb84a424c1501b12a9f6c4451600d03e1bce266acf45
- 59d60913b1c473eb4b9d13b833e76d8d4867f200c6a5cb42de8721e06aa44cbb
)
package() {
cd "$srcdir"
- install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname"
- install -Dm644 $pkgname.conf -t "$pkgdir/etc/$pkgname/"
- install -Dm644 $pkgname.hook -t "$pkgdir/usr/share/libalpm/hooks/"
+ install -Dm755 $pkgname.sh -t "$pkgdir/usr/bin/"
+ install -Dm644 config -t "$pkgdir/etc/$pkgname/"
+ install -Dm644 hook -t "$pkgdir/usr/share/libalpm/hooks/"
}
diff --git a/paclist.conf b/config
index 29fd1f6bd139..29fd1f6bd139 100644
--- a/paclist.conf
+++ b/config
diff --git a/paclist.hook b/paclist.hook
index f2c7acfb6156..b00f017cb4f9 100644
--- a/paclist.hook
+++ b/paclist.hook
@@ -5,5 +5,6 @@ Type = Package
Target = *
[Action]
+Description = Updating package lists...
When = PostTransaction
Exec = /bin/sh -c 'paclist <&- >&- 2>&- &'
diff --git a/paclist.sh b/paclist.sh
index ef1ba7905185..755b251a070f 100755
--- a/paclist.sh
+++ b/paclist.sh
@@ -5,7 +5,7 @@
export PATH="${PATH}:/usr/bin:/usr/local/bin"
# load and check configuration
-. /etc/paclist/paclist.conf || exit 1
+. /etc/paclist/config || exit 1
[ ${#lists[@]} -lt 4 ] && exit 1
[ $(( ${#lists[@]} % 4 )) -ne 0 ] && exit 1